[1.12.0.0] crcfix.exe has stopped working

Hey folks,

When create a new (empty) project I get the following error:

6115-crcfix.png

Any ideas?

Same thing here. I’m getting incredibly frustrated with this engine, fighting the thing before it’s even open is not a good sign.

Literally hit every single one of those errors. Trying to build gems is also fraught with error messages.

EDIT: Attempting it again and will post back here (seems like having one source for both of these problems is on-topic given they are sequential problems) when it finishes.

EDIT 2: Got an Asset Processor error about gems being unbuilt WHILE building gems.

I am having the same issue as everyone above. How long did it take for it to build for you?

EDIT Nevermind, it just finished building.

@Twolewis When the window pops up do you hit close program? I had the same thing happen and I just let it finish building without hitting close program and leaving the window up… Have you tried this?

Same here…

First:

6163-1.png

Then after trying to launch the project:

6164-2.png

And:

6165-3.png

@Rithiel About ten minutes or so. Let me know if it worked.

What Command are you using to build the project? Also I don’t know if this would work but have you tried going into Task Manager and ending the Asset Processor program?

Just leaving it running doesn’t work for me.

Is there a working fix for this? :slight_smile:

Opening the Project Configurator as administrator has worked for me

Hey folks – I’m very sorry for this extremely frustrating experience. Let me fetch some answers on this issue in parallel to efforts @JonTheGlitch (thanks Jon!)

Yeah, it worked. Thanks for your reply!

Nice! Hey folks, does this help in your case as well?

Thank you :slight_smile:

Unfortunatley not, no :frowning:

Bleh – alrighty, thanks for trying @Depleted. Our team is working hard on fixing issue this as soon as humanly possible. Stay tuned for updates and again apologies for the troubles.

@Techtime @Depleted @Amonster_LMBR

I was dealing with this problem and got a working solution:

  1. I created my project from the console command

  2. stopped it when it the crcfix error came up (build seemed to stop there / no new files being generated)

  3. set your new project as default (either through project config or console).

  • note: I noticed when using the project configurator, my project folder would be deleted but not when creating through the console.
  1. lmbr_waf configure

  2. open the solution generated from configure, and build in VS

  • note: this last step probably would have worked using lmbr_waf build_… but didn’t test that

Hope this works for some others!

Hey @naotoy what was the name of the solution generated from configure and what type of build did you do in VS?

@Amonster_LMBR Any fix for this? I’m also having this problem

Hey @Techtime, @Depleted – Looks like the team has target a fix for an upcoming release! :smiley: Apologies for the delays on this topic and troubles with this process :frowning: