[1.7] Debugger not working [Win 10 x64][BUG]


As I see lua debugger still not working in LY 1.7. It’s the same as described:



I observed that at documentation in GridHub you have different logs with different Qt libraries name. At my computer I have for e.g. (Qt5Core) but at your documentation I see (Qt5Cored). Maybe mismatch with libraries cause this problem ?

Also I have this warning:

13:46:58|GridMate : Trace::Warning

d:\ly\workspace\PKG_v1_7\dev\Code\Framework\GridMate\GridMate\Replica\Replica.cpp(657): ‘bool __cdecl GridMateForTools::Replica::Unmarshal(struct GridMateForTools::UnmarshalContext &)’

13:46:58|GridMate : Received unknown replica chunk type 0x6f69ff36 at index 1, discarding 26 bytes.

which as I see GridHub was not touched in LY 1.7 (is the same version as earlier).

ps. Lua Remote Debugger not working as well.

Do you provide source code for GridHub and LuaIde to try find solution by myself ? Do you have other ideas what can cause that LuaIde do not see any targets ?

Hey @jasiuj, I’m going to have one of our techs look at this, it sounds like there may be a bigger issue going on here. Sorry for the continued issues you re experiencing.

…and the problem went away. Not sure what the heck happened, but it’s working now. Weird.

I’m having a similar experience, though a bit different Error. I did a fresh install of Lumberyard, setup fine, added the Woodland asset package to the samples project, and none of the projects will run now. I keep getting

“An error has occurred!
We still have 407 allocations on record! They must be freed prior to destroy!”

Not sure where this is coming from, I don’t even have a d: drive on the computer. Apologies if this is the wrong place to ask about this, I’m still very new to Lumberyard.

That is weird… glad it worked itself out. Please start a new thread if that particular error happens again, that’ll help us track the issue and get it resolved more quickly.

Hi @AdamC I’m glad that it’s working for you. Could you confirm that lua debugger is working for you ? Do you use Windows 10 x64 ?

Could you provide dxdiag file (run c:\Windows\SysWOW64\dxdiag.exe then save information to file, compress it (to be able to upload file) and attach it to this thread, it’s DirectX component which generate information about your computer and some software as mine: 3676-dxdiag6.zip (14.4 KB)dxdiag6.zip ). This could be usefull to find differences in our configuration to solve the problem.

I hope that this will be fixed.

Hey @Binky_LY, this is important because in LY 1.7 are big warning to not use Flow Graph because it will be deleted and ask to use Lua instead. But without debugging it’s quite difficult and no one can downgrade their Windows 10 to earlier version to use it. So it’s quite big problem for user or studios with new version of Windows (where currently you can buy only Windows 10). Do you reproduce this problem ? How can I help you to resolve it ?


I am sorry for double my question, I will close other threads to stay active just this one.

Hi @Binky_LY and @AdamC,

The problem is some where at my side. I try it on a clean copy of Windows 10 at virtual machine and there is working. So I am going to reinstall my Windows at the moment. Thanks you for your helping, and sorry for problem from my side :wink:

Hi @Binky_LY,


Re installation of Windows solve problem fore me :slight_smile: Thanks for helping :slight_smile:

@ jasiuj Hi. Sorry this is way too late and it’s probably solved by now, but for anyone else who is having this problem, Don’t reinstall Windows. It’s a waste of time. The problem that fixed it for me is really simple. Install Visual Studio 2015. That’s it, I had this problem, and once Visual Studio Community 2015 was installed. It started perfectly. (Also don’t forget to select the C++ language when installing).