After installation of Visual STudio 2015 - Everything broke

So, I tried to publish my game to AWS, so in order todo that I needed to get MFC-support. So I installed Microsoft Visual Studio 2015, and after that I can not start the LumberLauncher at all. Not the demo-projects, nor a new clean project. I always get the error "Game can not be initialized, please refer to the editor log file.

But there is not any editor.log-file anywhere in my filesystem!

So… after some heavy reading I found out it was suppose to be Visual Studio 2013 Community that I was suppose to installed !! :frowning:

So, after I have installed Visual Studio 2013, it still does not work to start any project.

So, I followed the instruction “You must compile your project before…” So, I did that , I ran the command:

lmbr_waf build_win_x64_profile -p all --progress

And waited a LONG time for it to compile…

Tried to start the Lumberyard-editor after the compilation…

No success!! Still the same error.

So, now I am on the process of unpacking the whole Lumberyard-package again… and start from skratch!

Hopefully I do not have to re-install a complete new Windows 10

I will update you guys again.

Hi,

Yes, I have rebooted my PC several times.

I tried “lmbr_waf configure” , but still no success.

What bother me the most is the error message is reffering to the “editor log fil” … but that is nowhere to be found in my whole file system. I have made a file search on the whole drive… non-existing. So, I am walking blind here.

I am halfway through the process of unpacking and setting up a new environment now. Hope it works.

Hello @milkosten,

Apologies that you having issues launching the Editor. Let me try to troubleshoot this with you:

  • After re-installing Visual Studio 2013, have you tried to launch the LumberyardLauncher.bat file? If so, please make sure that you have all required Software and SDKs installed. For more information, please follow the Setting up your development environment tutorial
  • Also, please make sure to run lmbr_waf configure before launching the editor, this should auto-detect your newly installed software and provide you with information regarding any missing software/sdks that are required for running the Lumberyard Editor.
    If you are still having issues, please let us know!

Thanks!

… And just to answer your questions. Yes, since I rebooted my PC, I started the LumberyardLauncher.bat file again.

In the “Lumberyard-launcher” all things where green, saying that all was OK.


Update on my re-installation.

Now that I have unpacked the lumberyard-files again in a new catalog I can start the editor again.

Now I just need to install all the assets and find out how to import my old game that I had developed into this new installation.

Thank you for your support!

Awesome.

Regarding your previous question, you can locate the editor.log file here: {Lumberyard_Installation_Folder}\dev\cache{Project_Name}\pc\user\log\

Please let us know if you still encountering any more issues!

Thank you for using Lumberyard!