Are Particle Effects Bugged?

I have created a simple particle effect within the editor that looks like a ball of lightning. It animates and looks great but there is a small problem that I’ve spent three days trying to resolve now. The view-ability of the particle becomes clipped at specific angles and therefore shows the particle either partially or not at all. I will include screenshots below that demonstrate what I am talking about.

  • I have the facing set to “Camera”.
  • I have a single particle that does not move but is animated at the position of the emitter (“Space Loop” is checked as enabled).
  • There is a line drawn from the origin of the emitter to the world origin.
    • This line seems to be related to my problem.
      • As long as my camera includes the particle and is facing towards the world origin I can see the entire particle.
      • When I move my camera between the world origin and my particle and I am facing my particle it becomes “clipped” or invisible.
  • For clarification I will try to help visualize the camera positioning.
    • Let “E” represent my emitter with the particle.
    • Let “C” represent my camera.
    • Let “O” represent my world origin.
    • Shown properly
      • C ----> E ----> O
    • Clipped or invisible
      • E <---- C <---- O
  • The particle always faces the camera but it is as if the normals for the plane it is being drawn on do not.
    Essentially if I view “behind” the emitter the particle becomes invisible and if I view the “front” of the emitter the particle is perfectly visible. I have tested the behavior in both the editor and in game mode.
  1. What is causing this problem?
  2. How can I fix it to where the “front” of the emitter is always facing the active camera?

Hello @Mucher,

I tested this out locally myself and didn’t notice the same issue you are experiencing. I did notice that the line leading to your particle emitter looks as if the particle is linked to another object, possibly the cube with the stone texture on it? Or as you said linked to something else close to the world origin.

If so I would try removing that linking and try again. I’m wondering if your particle is inheriting some weird position or orientation values because of the linking. To remove it, select your particle and press the “Unlink Selection” button in the toolbar:

On a side note, our Particle Editor is still in beta. So we appreciate this kind of feedback as it will help to make our systems better. Please let us know if you’re still having an issue so we can try to solve it.

Thanks for such a quick reply Jason! I followed your instructions, selected the emitter, and clicked the unlink button. This successfully removed the line from my emitter to whatever it was linked to. I guess when I use snap to objects when I drag it into my level it creates this link automatically?

Unfortunately this did not resolve my issue. I am still experiencing the invisibility/clipping issue. Oddly enough the problem still occurs in relation (or in a seeming relation) to where the link line was previously.

In an effort to recreate my problem exactly, I will include the image I am using as the texture for my particle below. I will also list the exact steps that I am taking to create this particle in case I am missing a step or performing a step incorrectly.

  1. Open either database view and go to particles tab or open the particle editor. I have tested creating the particle with both and get the exact same issue.
  2. Create a new library named “Spells”.
  3. Create a new folder/group named “Lightning”.
  4. Create a new item with the name “Spark1”.
  5. Set “Count” to 1.
  6. Enable “Continuous”.
  7. Set the texture to the one I am including below (though I had to reduce the quality in order to share it here due to its 3.5MB size).
  8. Make sure “Particle Life” is set to 0.
  9. Set “Blend Type” to Additive (this was the only way I could remove the black background from the texture, even though the best practices documentation says to use alphabased I could not get the image I wanted using that).
  10. In texture tiling
  11. Set both “Tiles X” and “Tiles Y” to 2 (since the texture is 2x2).
  12. Set “First Tile” to 1.
  13. Set “Animation Frames Count” to 4 (since there are 2x2 images being animated).
  14. Set the “Animation Framerate” to 15.
  15. Set the “Animation Cycle” to loop.
  16. Change the “Size X” and “Size Y” to 5 to make it 5 times larger in scale.
  17. Set “Speed” to 0.
  18. Drag and drop the “Spark1” particle into the level.
  19. Select the “Spark1” emitter and clicked unlink.
  20. Moved the camera around.
  21. Cried a little when it didn’t fix my problem.

Just realized that in order to be viewable, it’s not related to the direction that link line was drawn, but more specifically has to do with looking at it from positive x, y, and z. It disappears when I move the camera to face it from a negative x, y, and z direction. I moved the emitter clear away from my platform to test this. Screenshots for proof (notice the widget arrows that show the positive and negative directions).

The clue to the solution was in the second response I made to Jason. The side that was showing was because it was the only side with light shining on it from the moon light. This implicates that if you try to recreate this in a level with lots of lighting you would not notice it.

In order to fix this I simply changed the “Diffuse Backlighting” to a value of 1 (it was defaulted to a value of 0). I might suggest making this setting have a default value of 1 in a future build.

Thanks again @Jason for your time and effort! Hopefully this will help others in the future.

@Mucher,

I’m glad you were able to resolve this. I did not think to test this in the same lighting conditions you had. I tested in a daylight setting which explains why I didn’t experience the same thing.

I will make a suggestion to our development team to update that default value.

Again, thanks for your patience and I’m glad to see you resolved this. Please let us know if you have any more questions.