Asset Processor doesn't rebuild catalog

I’m facing an issue with the Asset Processor not working properly. This becomes a huge headache as the only workaround I’ve discovered is to constantly kill the asset processor and restart the editor. This issue occurs persistently (have not found a configuration which doesn’t trigger it) but sporadically (have not found a configuration which always triggers it) which makes it very difficult to debug. This is an extremely painful interruption of our workflow and I can only assume we are doing something very wrong, or the Asset Processor is very broken.

When the AP correctly completes a job (e.g. after I copy a file to the game directory), I see log output like:

Processing My_Asset (pc)...
Processed "My_Asset" ("pc")...
Saved pc catalog containing 3640 assets in 0.035000s

Sometimes when importing an asset (either by copying the file, or using the ‘Import…’ dialogue) I don’t see this output. Sometimes the ‘saved pc catalog’ line does not appear; in this case an editor restart usually picks up the new assets. Sometimes even the ‘processing’ line doesn’t appear; in this case I need to exit the asset processor and restart the engine. I haven’t noticed any correlation between how the error presents and what process was used to attempt to import an asset.

Hey @yuriy000 – I’m sorry for the troubles. What version of Lumberyard are you using for this AP issue?

Hello @yuriy000,

I’ve seen this behavior before. It is usually due to the use of symbolic links or shortcuts which the AssetProcessor does not handle properly. I would recommend against using symbolic links.

Hope that helps.

Thanks, looks like that is the case. The project folder was indeed a symlink; placing the real directory in the dev' folder fixed it. I remember finding a post on these forums stating that that is the approved way to have a project live elsewhere than thedev’ directory (unfortunately, cannot find it now) but it was quite old - possibly outdated, possibly never worked.

I’ve posted a follow-up to this question (hoping to finally achieve my goal of having game projects outside of the dev directory): https://forums.awsgametech.com/t/how-to-use-functionality-which-allows-creating-your-game-project-directory-outside-of-the-lumberyard-engine-directory-with-an-existing-project/4755/1