AttributeValue Error: Invalid player; attribute skill has the wrong type (expected=number)

I want to make a StartMatchmakingRequest so I tried to create 2 players and add attributes to each player.
The rule set I used which was the sample one:
image

here was my code:
Aws::GameLift::Model::Player p2;
// …
Aws::GameLift::Model::AttributeValue attribute2;
attribute2.SetN(25.0);
p2.AddPlayerAttributes(Aws::String(“skill”),attribute2);

And This was the error I got:

HTTP response code: 400
Exception name: InvalidRequestException
Error message: Invalid player; attribute skill has the wrong type (expected=number); player id = 1000
5 response headers:
connection : close
content-length : 135
content-type : application/x-amz-json-1.1
date : Wed, 13 May 2020 02:47:04 GMT

Could anyone help me with this? Thanks.

Can you let me know if you’re using this code from Lumberyard (if so which version) or elsewhere? Asking because Lumberyard provides its own pre-compiled version of the AWS C++ SDK.

This seems like a bug.

Can you provide your Matchmaking config, ruleset id and region along with any approximate times of the calls and I can get the GameLift service team to investigate.

Hi Pip, I’m sorry for this late reply. Recently, I was migrating all the server things to another aws account. I didn’t get the opportunity to retry this until now. However, I found I could not reproduce this issue again. I used the same project and the same settings. Maybe this has been fixed.

So… It seems to be solved.

Again, thank you for your help.