AWS CLI command create-build creates broken builds with SizeOnDisk 0

Hello,

I am having difficulties using the cli command create-build to create builds from my S3 bucket. The problem is that although the process seems to work, it creates broken builds with SizeOnDisk set to 0 that when deployed into a fleet, makes the fleet change to FLEET_STATE_ERROR just after FLEET_STATE_DOWNLOADING with no logs or information about what exactly happened.

Fleet ID:

fleet-19f1a3e2-cd37-4ea4-82dc-92c336ee5336

Dear @Ben

  1. It does work properly if I upload it with upload-build.

  2. Yep, I can unzip it and run it locally perfectly fine.

  3. There is no instance to connect to, this is what the event log shows: https://puu.sh/yFFzm/205cef9f46.png It seems to fail when trying to download or create the AMI?

Dear @Ben,

Not trying to be impatient but this issue has basically blocked the development of our GameLift integration.

Kind Regards

Hi @aftokinito, we have a known issue where size shows 0.00MB when you upload a build from an S3 bucket. However, it should work properly. Is this a build that has worked for you in the past? Does it activate properly if you upload it using upload-build?

Can you try logging onto your instance to see if the build is there? You’ll need to configure your RDP/SSH ports before launching the fleet.

Ben

If this is not fixed, I will be forced to move away from AWS. The other major cloud providers don’t force me to pay for premium support in order to get acceptable response times on issues that are caused by their own platform. I find it ridiculous that a company like Amazon that has such incredible support on their storefront is also that much incapable of providing working solutions to its low tier customers.

Absolutely incredible.
@Ben @Matchmaker

Hi @aftokinto, I’m investigating your failure but haven’t found anything yet. Can you upload a new build to S3 and run create-build again and provide the build-id and fleet-id? Can you also share your trust policy and inline access policy?

Ben

@aftokinto, on the access policy X out your bucket name. I just want to make sure the rest of it is correct.

Dear @Ben,

Fleet ID: fleet-bb9c8e71-feb6-4f83-abab-985b23442df9

Build ID: build-84ea4875-ff2a-41af-9e37-5d140a808a7f

Inline:

    {
"Version": "2012-10-17",
"Statement": [
{
"Action": [
"s3:GetObject",
"s3:GetObjectVersion",
"s3:GetObjectMetadata"
],
"Resource": "X",
"Effect": "Allow"
}
]
}

Trust Policy:

  {
"Version": "2012-10-17",
"Statement": [
{
"Effect": "Allow",
"Principal": {
"Service": "gamelift.amazonaws.com"
},
"Action": "sts:AssumeRole"
}
]
}

Hi @aftokinito, In order to troubleshoot this I’ll need to log onto one of your instances. Unfortunately the instance from this morning has already been cleaned up. Can you create a new fleet and can I have permission to log onto a fleet instance?

Thanks,

Ben

Thanks @aftokinito, I’m taking a look.

Ben

Dear @Ben,

The fleet is creating as we speak (fleet-ffe29dea-f05c-48a8-99f1-5cab63e2505a) and I grant you my permission to access it.

Kind Regards.

Thanks @aftokinito, taking a look.

Hi @aftokinito, can you try opening up your access policy? If it works we can narrow it down afterwards.

            "Effect": "Allow",
"Action": [
"s3:*"
],
"Resource": "*"
<br>

Can you also double check to make sure your policy is attached to your gamelift trust role?

Thanks,

Ben

Dear @Ben:

Unfortunately changing the policy did not resolve the issue.

Kind Regards.

Hi @aftokinito, to debug this further I think we’ll need some info that isn’t safe to post on the forum. Can you email ly-community@amazon.com with your email address?

They’ll relay it to me and we can continue troubleshooting.

Thanks,

Ben

Hi @aftokinito, I think we figured this out. Can you try removing the dots from your bucket name and create a new build with create-build?

We’re looking into a fix, but for now removing the dots should unblock you.

Ben

Is there any update regarding the dots bug? I need this fixed since I am using the same bucket to grab the build for GameLift and as a release channel so I need the bucket to work with the “static website hosting” option enabled (it doesn’t without the dots).

Hi @aftokinto, after digging a bit I think I understand the problem. You are correct, the bucket name needs to be the same as the CNAME you’re creating. Per documentation here:

Ben