Building Gamelift SDK Linux binaries Automake error

/mnt/e/Source/GameLift_02_15_2018/GameLift-SDK-Release-3.2.1/GameLift-Cpp-ServerSDK-3.2.1/lout/thirdparty/protobuf/missing: line 81: automake-1.14: command not found

Seems as though somewhere in the make files for the SDK Automake 1.14 is required. Unfortunately I am not a super user of Linux so im having a hard time trying to figure out how to downgrade to 1.14 as 1.15.1 is currently the distributed version with Ubuntu. Any help would be appreciated.

Or if someone has a current binary for linux they can share I suppose that would work as well.

EDIT: Based on some other posts I have seen the GameSpark devs say they are working in Ubunutu 14.04 which should come with the proper automake. Spinning up an EC2 instance to give this a try and see if I can successfully compile the linux binaries that way.

EDIT 2: So tried building on an ubuntu 14.04 ami and ran into all sorts of new issues about curl and ssl so it couldnt even download the boost stuff during the make. Is there an AMI or particular build you guys use to compile your linux binaries?

Hi @DeadlyMidnight, Sorry for the delay in responding. I would recommend building on Amazon Linux since then you will be building against libraries that will be present when you launch a GameLift fleet.

However you will still run into some of these problems building. The version of curl that CMake uses by default does not have SSL enabled.

To enable SSL I do the follow.

  1. Download the CMake source from here: https://cmake.org/download/
  2. Install libcurl-devel
  3. Bootstrap CMake to use system curl: ./bootstrap --system-curl
  4. Make and make install CMake.
    I hope this helps!

Ben

Ben thanks so much for the update on this, I am going to give it a whirl right now and see if I can get the Amazon Linux to compile it.

Installing the cmake using the suggested method resulted in a very clean no error happy compile. Though the file created was prefaced with lib, so libaws-cpp-sdk-gamelift-server.so

I renamed to match the expected file name, not sure why its coming out like that.