Building lumberyard problem

I’m using 1.25 made a new project then I add all the gems but the multiplayer and cloud gems. started building with ./lmbr_waf build_win_x64_vs2017_profile -p game_and_engine it builds about halfway before I got an error. it was something about the video playback gem so I removed them from my gem list and compiled again. the compile process seemed to have almost started where it left off so it was like 5000 of 8000. it finished and said it completed successfully. I open ly and I get this error.
image


so I go to rebuild again and it builds for like a min and says successful. any idea on what is going on

Hi @phil_blackwood,

Sorry to hear you’ve been having problems getting Lumberyard to build, it does sound very frustrating.

I’ve encountered issues like this before in the past and there’s a few things you can try. The first thing I’d check is the timestamp of the Gem.qwerty.220f.... file - there’s a chance it has not been built but is still trying to be loaded (it might be out of date). If it looks old, try making sure that the Gem is enabled in Project Configurator (you might want to try disabling and enabling it again too). You can also delete the .dll file and then try running again (you might hit another error or it might work) if it still fails to run try buiding again and the .dll should be regenerated (so long as the Gem is enabled).

Can you give that a try and let me know if you have any luck?

Thanks!

Tom