Calling restful APIs via Http

In Lumberyard 1.0, I built a Gem that relies on making HTTP requests via aws core http module. I’m trying to update, but it seems that this was removed by 1.3.

What is the replacement? What is the best way to make http post API calls?

UPDATE: It seems that it wasn’t removed, but the dependency doesn’t work anymore.
How do I properly re-setup my dependencies on these?:

#include <aws/core/utils/memory/stl/AWSString.h>
#include "aws/core/http/HttpTypes.h"
#include "aws/core/http/HttpResponse.h"
#include <aws/core/http/HttpClientFactory.h>

.

The correct wscript was this:

    def build(bld):
import lumberyard_sdks
bld.DefineGem(
includes = [bld.Path('Code/CryEngine/CryAction'),
bld.Path('Code/CryEngine/CryAction/FlowSystem/Nodes'),
bld.Path('Code/CryEngine/LmbrAWS')],
win_use = bld.make_aws_library_task_list(['aws-cpp-sdk-core']),
win_features = ['AWSNativeSDK']
)

the ‘.’ and ‘…’ paths cause “lmbr_waf configure” to throw exceptions when put into a gem. (or at least my gem?)

The rest works, but mine is the actual (apparent) minimal set of requirements.

Hi @PGilmore,

I’m looking into this, have you tried using the same approach as the AWS 1.3 gem?

The wscript for that has changed the Path command to bld.Path, added an import lumberyard_sdks command and a win_use command.

    def build(bld):
import lumberyard_sdks
bld.DefineGem(
includes = [ '.' , '..', bld.Path('Code/CryEngine/CryAction'),
bld.Path('Code/CryEngine/LmbrAWS')],
win_use = bld.make_aws_library_task_list(lumberyard_sdks.BuildNativeSDKLibraryList()),
win_features= ['AWSNativeSDK']

Thanks for posting the solution @PGilmore! Glad to hear it’s working for you.

Thanks! You definitely got me closer to the solution. I tried to randomly cherry pick wscript lines from other gems, but I wasn’t really finding the right combination.