Can not login to AWS and hence can not run editor.

pic.jpg

As you can see from the attachment.

I can not put anything on username/password field. No matter what I type, it does not show up on the fields.

Why is this?

Regards,

Kaiyum

//edit: Please look into the log files if you see any errors and post them here. The log files can be found here: \dev\cache<project>\pc\user\log

//original:

Hard to find the issue like that.

Maybe you could try to start the editor out of Visual Studio and look for any errors or warnings?

There are 2 great tutorials, showing how to build and start the editor out of VS: https://s3.amazonaws.com/gamedev-tutorials/Tutorials/Programming-Basics-(01)_Setting_up_your_development_environment_v1.pdf & https://s3.amazonaws.com/gamedev-tutorials/Tutorials/Programming-Basics-(02)_Compiling_the_Engine_Editor_and_Game_v1.pdf

Cheers,

Martin

Thanks. Sadly, I don’t see any errors related to your issue in these logs.

Maybe someone from AZ can help you (@ChrisDB)

I have built the solution from visual studio too. Sadly the same error. AWS window pops up which I can not skip and I can not put my credential there either.

Is there a forum where I can discuss further details as it is not a public build, due to NDA? It is a PS4 build.

Sadly no. I only have PS4 build.

Hi KaiyumRPC.

Do you have the public build of Lumberyard? If you do, does the login screen work in this build?

Hi Martin, the log is in the attachment. 1182-editor.zip (3.86 KB)editor.zip and 1183-awslogs.zip (1.28 KB)awslogs.zip

Hi James,

I am on windows 8 pro 64 bit. Its a dedicated machine.

I
was connected to internet and about firewall part, I am not sure. As far as I can remember I did not explicitly blocked any amazon connection. Its a static IP. I tried from other static IPs assigned to our company too, those IPs are also registered at sony DevNet. In case of any third party software blocked amazon or such, how can I investigate the case?

Not only the texts are disappearing, but also whether I type on those two input fields or not, its the same. Even
if I try copying and pasting something to those fields, it does not work. I can explicitly give a thing to try. That is to modify the source
so that editor never requires aws login. But I wonder how feasible it is, and if it is against amazon’s policy or such…

Many thanks,

Kaiyum

Hi @KaiyumRPC

Given that the text on the buttons isn’t appearing, it looks like it’s lost connection. The other thing I would be curious about is if there is a modal (blocking) dialog box open that is stealing input.

A few other questions for you to help diagnose:

  • What version of Windows are you on?
  • Are you on a 32- or 64-bit version of Windows?
  • Are you running on a dedicated machine, or via a VM?
  • Is that machine connected to the internet?
  • Are there any firewalls (corporate or government) that might be blocking access to https://amazon.com?
  • Are you connected via VPN?

Do you happen to have a 4K monitor or a high-DPI setting? The presence of buttons but lack of text implies that the login screen is able to reach out and download the content (button images, etc.), but isn’t rendering the text properly.

No its viewsonic vx2270, resolution set to HD(1920x1080). I still can not login to AWS. Please help.

@ChrisDB

can you take a look at it please?

Hello @KaiyumRPC,

Can you please test this out with the regular Lumberyard install and let us know if you experience the same issue? In the meantime, we will investigate this further and hopefully have a solution for you soon.

Thanks!

Hello again @KaiyumRPC,

Just wanted to check back with you and see if you have made any progress on running the Lumberyard Editor. I had a couple more suggestions to make:

  • Try to flush your DNS cache
  • Verify that there are no proxies or firewall that could be blocking access to amazon.com
  • Also, try just hitting http://www.amazon.com in your browser and see if you can login there.

If none of the above work, I would suggest sending us an email at lumberyard-feedback@amazon.com and we will try our best to help you out.

Thanks!