Cannot create new project

When creating a new project it comes to Build project and then comes up with Error executing WAF. (see log for details). The error inside the log is

Target platform “win_x64_vs2015” not supported. [on host platform: win32]

Please help me get around that.

Thank you.

@romanturaev I personally haven’t had this problem, but I found someone who had the same error here. Do you have the Common Tools for Visual Studio 2015 and Microsoft Foundation Classes (MFC) for C++ installed on your computer?

Hi @romanturaev, sorry for the inconvience. We’re working on getting this fixed ASAP. Stay tuned for updates!

Here’s a related post:

https://forums.awsgametech.com/t/cant-create-new-project-waf-error/4458/1

2019 version 1.22 and the problem is still not solved. I am trying to solve it myself by researching and it takes the focus from game development to “engine fixing”.

Update: 22/12/2019

The issue was resolved the problem appearantly is in the dev/WAF/user_settings.options

This line was commented

;win_vs2017_vswhere_args = -version [15,16]

Just remove the simicolon in front of the line to make it be

win_vs2017_vswhere_args = -version [15,16]

However the build time took ages on an i7 7700K overclocked to 4.7GHZ I will test the building time on a Dual Xeon system we have at work and post the results back.