Can't connect to GameLift server

Hello everyone.
Well, my problem is quite straightforward: my GameClient.exe is unable to connect to the IP and port provided by GameLift. Can’t identify the issue because the logs complain about nothing.
Notes:

  1. My fleet is ACTIVE.

  2. I’ve tried with and without an ACTIVE GameSession–same result for both cases.

  3. The :7777 UDP port is open (according to the Dashboard and netstat -a).

  4. When remotely accessing the fleet’s correspondent instance, the Task Manager has a process of my GameServer.exe running.

  5. My GameClient.exe successfully connects to my GameServer.exe locally when running it against GameLiftLocal.

  6. The GameServer.exe instance on the fleet is listening against the correct port. In this case, 7777.

  7. My man-in-the-middle is GameSparks.

After my several failing attempts, I read this entire document, and I could successfully achieve everything until (and including) CreatePlayerSession. However, in the very last part (Connect to a game session.), you mention the following:

In order to claim the reserved player slot, the connection request must reference the player session ID.

My question is: how do I reference the player session ID in the connection request? And what exactly do you mean by “connection request”?
I am using Unreal Engine 4.18.3 and attempting to connect using the Open Level node. Should I pass a ?playerSessionID= option, referencing the PlayerSessionID as its value? Is that it?

If needed, our fleet ID is fleet-acf1a947-e537-4f2d-8004-31d2e6aeba59.

Sorry for spamming all these questions the last days. We’re on a tight deadline and this forum is being our last resort on getting things clarified.

Best regards,
Guilherme.

Well guys, no success so far.

I’ve tried to run my GameServer.exe on a virtual machine (against GameLiftLocal) and others can connect to it successfully. That being said:

  1. Not a problem on the client.
  2. Both my machine and a VM can host my server successfully.

Am struggling with this 2 days now and running out of options.

No ideas, guys?

(I have the subtle impression this is something related to port forwarding or something, but I can’t think what I could’ve done wrong. Followed this doc.)

Hey everyone,

I’ve recreated the fleet–with the same build–and suddenly it started receiving players. Honestly, I’ve potentially done something wrong, but I can’t say exactly what–the procedure to create this latest, working fleet was the same as the previous, malfunctioning one.

Allow me to apologize for the spam.

Resolved.

Hi, i have a question. ¿What is the best way to connect the Server and the client ? what library do you use for this job ? Thanks