Can't install older version of Lumberyard?

I have the install file for an old version of Lumberyard I was using before I had to format my drive, but it doesn’t let me install it. It gives me the error “0x80070005 - Access is denied.”

Anyone know why that’s happening?