Can't upload a build to GameLift

Hey guys,

as my project growes it is not possible for me anymore to upload a build. I have tried it now 10 times and i always get two different errors:

1.) The write operation timed out

2.) Something with “connection was aborted”

Usually the errors happens in the 50 - 60% or 90 - 95% range. I’m using the following command

aws gamelift upload-build --name "BUILD" --build-version "1.0" --build-root path

The size of the build is about 340MB when GameLift zips it (the folder itself is about 600MB). My upload speed is 2k, so it takes a while to upload (~30mins).

Anyone knows why the upload process always fails? :confused: (Occasionally it happened before with a smaller size of the project)

Thanks :slight_smile:

SH

After a couple more tries it worked out. But i would really appreciate to know why this happens.

Hi @SilvanHau, sorry you’re running into this problem. You may be able to avoid timing out by modifying your S3 client configuration.

If that doesn’t do the trick, try lowering max_concurrent_requests as well. That way each chunk will have
more bandwidth but it will slow down the upload over all.

If it’s still failing you can try uploading to S3 first and then sending it to GameLift.

Ben