Crash when I try to create level

Everytime i load the editor and try to create a level it crashes. Any help for this?

Hi @petrocket

I have the same problem as @Winterstone. I thought at first it might be because of not having the right edition of Visual Studio. I initially had (and still have) VS 2015 Community Edition. I added VS 2013 Express Edition but wasn’t able to add the MBCS MFC Library to that because of Express Edition not allowing add-ons; however I have now removed the Express edition and installed VS2013 Community Edition along with MBCS, and the problem still persists.

I can’t open the sample levels, and I can’t open a newly-created blank level either. I get the same message as Winterstone in all cases

I’ve downloaded all the .zip files but so far I’ve only unzipped Lumberyard. This is on a Windows 10 machine.

Hi @Winterstone!

Thanks for reporting this. We’re currently investigating the issue. I have a couple questions if you don’t mind:

  • Can you open any of the samples levels in the editor?
  • Did you download and extract all the .zip files (Lumberyard, Woodland, BeachCity etc.) or just Lumberyard?

It happened trying to open a sample level as well.

I just downloaded Lumberyard. Thanks for investigating.

@petrocket Another guess as to what the problem might be: My machine is perhaps somewhat under-specified. Rather than being a high-end gaming machine, it’s a laptop with an Intel chipset, It has 6GB RAM instead of the recommended 8. But it does run simple DX 12 programs as generated by VS 2015, so I did hope that it would at least run Lumberyard, albeit maybe a little slowly. But maybe not.

@Winterstone, what’s the spec of your machine?

Could you post the contents of your editor.log?

My editor.log is quite large so I won’t post the whole of it. I think the relevant part is

<21:58:50> ****** D3D11 CryRender Stats ******
<21:58:50> Driver description: Intel(R) HD Graphics
<21:58:51> Feature level: DirectX 10.1

Because my machine was able to run the VS2015 DX12 example program I assumed it was DX11+ compatible, but that is apparently not the case. Is there any way to"dial down" the graphic requirements of the Lumberyard editor so it will at least load up in a DX 10.1 environment?

The actual error in the log is

<21:59:02> Initializing CryFont done, MemUsage=76Kb
<CRITICAL EXCEPTION>
Exception: 0xC0000005, at Address: 0x0033:0x00007FFF863D2A30
Virtual memory usage: 325Mb
Debug Status: Last D3D debug message: No message queued. Debug runtime might be inactive or not installed.
Exception Code: 0xC0000005
Exception Addr: 0x0033:0x00007FFF863D2A30
Exception Module: igd10umd64.dll
Exception Name : EXCEPTION_ACCESS_VIOLATION
Exception Description: Attempt to read from address 0x00000269597B4000
The memory could not be "read"

Just rename the file to editor.txt and try attaching again. I’m thinking the attachment system is not liking the multiple extensions in the file name.

Hopefully this will work for you.

Mine was installed to my storage drive E:\dev

All the contents were install there and the .bat file was by itself. I deleted it and am installing to my C:\ in a new folder Lumberyard

Hey @MTGradwell, being able to see your full log would be very useful. Can you please reply and attach your log so we can take a look?

Also, can both you and @Winterstone please reply back with the full path of your lumberyard dev folder? For example, mine is *C:\Lumberyard\dev*

Thanks!

Firstly, you’re are seriously under the requirement to use Lumberyard. Intel HD cards have never been supported in CE. But DX11 is backwards compatible…

Disclaimer: Anything you do is on you!. Ok, that out the way. Make sure you have the latest DX libraries. After that make sure you disconnect from the internet and disable any anti-virus, test it out enable anti-virus and tell us how you get on. Access exceptions on .DL’s happend all the time in Unity due to Mcafee.!

If it’s a source code compiled version, then it would make sense as to why certain anti-viruses go a little weird.

@Jason I’ve tried attaching editor.log but I get

"Your attachment must be one of: gif,png,jpg,jpeg,zip,tar.gz,pdf,txt"

and when I rename it to editor.log.copy.txt and try to upload I get “No such upload”.

Attempting to copy and paste it into this reply significantly exceeds the character limit.

My path is C:\Lumberyard\dev\ the same as yours.

As @ShadowK says,I am seriously under the requirement to use Lumberyard. I suspected as much as I was downloading it, but hoped this would just mean it would run slowly. While it’s not established with certainty that that is the cause of this particular error, I think it has to be likely.

@Winterstone This is great news and I’m glad to hear you’re up and running. I’ll be sure to note that you had an issue when running this from an external drive. It may be something that we need to look out for.

Okay my problem was fixed by just deleting and extracting to my 2TB drive E:/Lumberyard (New folder that I created). Then I ran .bat inside that folder.

P.S. @Jason, @sunnlok, I’m adding this postscript to copy you in so you’ll know I’ve uploaded my editor.log, in the comment above.

Also I’ve been finding that when I attempt to post, sometimes I click on the Submit button and it turns grey but nothing else happens. I have to copy my comment to the clipboard, refresh the page, and attempt to post again. That happened several times with the message containing editor.txt and I had to re-upload it each time, so there may be a few copies of editor.txt cluttering up the Amazon server.

Hi @Jason

DirectX was installed - there was a green tick in the Lumberyard Launcher to indicate that. I reinstalled, just in case it was improperly installed, but that didn’t help.

I think the D3DX_SDK_VERSION = message just means that the D3DX SDK is no longer shipped with Windows 10, and the functionality that was in it has been incorporated into the Windows SDK … and now I come to think of it, I haven’t installed the Windows 10 SDK. I’ll do that and let you know if it makes a difference.

OK, here is my editor.log file, renamed to editor.txt.

680-editor.txt (15.3 KB)editor.txt

Also, since running from an external drive seems to have cured the problem for Winterstone who had the same error message that I have, I’ll try that and see if it works for me. I don’t mind if it’s slow on my set-up, I’m just looking forward to seeing Lumberyard in operation.

Hi @MTGradwell,

We were able to look at your log and it’s possible that you do not have DirectX installed or it’s improperly installed.

These two lines are what we’re looking at:

  Last D3D debug message: No message queued. Debug runtime might
be inactive or not installed.
<21:58:50> D3DX_SDK_VERSION = <UNDEFINED>

You can install it by doing the following:

  1. Open the Lumberyard Launcher and navigate to the Required software tab.
  2. Locate the Microsoft DirectX Redistributable line and click on it’s Install It link.
  3. Follow the directions for the DirectX installation.
  4. Once DirectX is installed, click on the Summary tab and then click on the Close button
    Once completed, reopen the Editor and please let us know if this worked for you.

Running the Windows 10 SDK installer just resulted in a “your system is up to date” message. I don’t think it actually changed anything. I guess the SDK was already installed.

I’ve extracted Lumberyard to an external drive, at E:\Lumberyard and run it from there. Now I’m no longer getting an error message popping up. Unfortunately this does not mean that the editor is now running. Instead it’s failing silently. The editor.log file (609-editor.txt (10.7 KB)editor.txt) is significantly different from before. I suspect that the most significant lines are

Using FreeType 2.5.0
Initializing CryFont done, MemUsage=76Kb
[Warning] XML reader: Can't open file (Fonts/default.xml)
[Error] Error loading the default font from Fonts/default.xml. You're probably running the executable from the wrong working folder.
System Shutdown

Because I’m no longer getting the same error message as before, I suspect this new problem belongs in a new thread. It’ll have to wait for a while however as there’s other things I have to do right now, and the external drive is needed on my Linux machine. But I will be back. Thanks to @Jason etc. for all the help so far.