Create from values(Color) node does not work in Script Canvas 1.25

Hi LY team,
I was able to use a number of nodes in my projects this month(august 2020)
Looks like “Create from values”(Color) node , it doesn’t work.
I tried a lot but did not get results.


this is my graph, I know make random color , and random color node does work , I wanted to create three ui sliders(R,G,B) by producing the desired color using “Create from values”(Color) node but does not work :point_down:t2:
RandomcolorTest.zip (18.9 KB)

Hi @_AhmadKarami
I tested the node using the light component and the nodes appear to be working correctly.

the light:
image

I haven’t had a chance to test with the material yet

OK, Thanks but I tested for two material files , mat01 / mat02 , for both materials and two models does not work!

You have to look at all possibilities, the Create from Values Color node works perfectly fine. It is the Switch Param Color for material that is broken. It has been for a while. Try without the Create from values node and use the built in color even, it will still not work. So the Node that does not work is the Material Param Color node. Hope this helps :+1:

1 Like

Very strange! I really tried so hard! :thinking: :face_with_monocle:
But I think that is the Create from values problem.
Thanks but does not work! :pray:t2: :rose:

I agree, I tried it and found it’s Set Param Color that doesn’t work. I changed it for Set Param Vector4 and I passed in the color values in the 0-255 range and I was able to change it.

I’ve opened a support ticket on our side to look into it, in the meantime, you could use Set Param Vector4 and you’ll be able to achieve what you need.

Thanks for the info and the patience!

1 Like

@LS1 @WashedUpStudios I recorded a bug video of “Create from values”(Color) node (unlisted video) and I looked at all possibilities, please see :point_down:t2:

I do see what you are saying, but I am talking about the Material Param Color node, you are using the Material Owner Param Color node. My mistake you have both on your video but the one that makes the colors change is the Material Owner node that uses an entity not a material connection. I do see that it does not work when hooked up to the Create from Values Color node also with the Material Owner Node. That is strange.

1 Like

Thanks! it’s on our list of issues to look into, there definitely appear to be a problem related to the node returning values in the [0, 1.0] range rather than [0, 255]. We’ll have a fix in a future release.

2 Likes