CUSTOM project is not working in LY1.7.

yesterday i downloaded to ly1.7 and install it on my system. sampleproject is just opening in editor and launcher but unable to compiling for release bulid it takes several hours(2-3), so i stopped this process.

after that i am created a custom project with gems like rain,snow ,bodies etc( i had been also tried without gem like plane project ). after configuration of project in CMD, i run the editor then it is unable to open, only logo is appeard(when i set vs2015) and when i set to vs2013 and run the project after whole process , editor says to me “Game cannot inilialize”.

while i follwed all rule and regulation but it is not working, i don`t know tha what is actual problem.

i used these command in cmd “lmbr_waf configure” according to new docs .

thanks to reply , now i am able to open in editor

i am also tried game pakaging in released mode i found this is faulty.

Hi @deependra_LY,

According to the logs your deep.dll game library could not be loaded. Please confirm that you have a deep.dll file in your dev/bin64vc140 folder. If the file doesn’t exist then it must be built using the instructions above, otherwise if it cannot be loaded it is possible the file is old - check the modified date of the deep.dll and verify it’s not the dll from the previous version of Lumberyard. You can also delete the file and re-compile to make sure it is being generated.

Lastly, please post the build command you are using.

Thanks!

Hi @deependra_LY, you also need to run the build command after the configure command. Here are the steps copied from the official docs with the addition of the engine and asset pipeline option (http://docs.aws.amazon.com/lumberyard/latest/userguide/game-build-game-code.html)

Please note that the release build specification is only for your final game build that you ship to customers. When developing your game you should use the profile build specification.

To compile game code

  1. In Lumberyard Setup Assistant, select Compile the game and Compile the engine and asset pipeline. Follow the instructions on each page. For more information, see Running Lumberyard Setup Assistant.
  2. On the Summary page, click Configure project to create your game project using Project Configurator. For more information, see Project Configurator.
  3. In a command line window, run the following to generate the Visual Studio solution: lmbr_waf configure
  4. Build your project by doing one of the following:
  • In Visual Studio, select one of the [Game] specs from the Build Configuration drop-down menu. You can use[Game] Profile to start.
  • In a command line window, type one of the following:
    • If you are using Visual Studio 2013: lmbr_waf build_win_x64_vs2013_profile -p game
    • If you are using Visual Studio 2015: lmbr_waf build_win_x64_vs2015_profile -p game

i done but it is not working for me i am used zip file of ly1.7

i am sending editor_log files 3701-logs.zip (32.9 KB)logs.zip. .

release mode

Hi @deependra_LY,

The reason why you get this error is because you are attempting to compile while the ProjectConfigurator or SetupAssistant is running and the .exe is using the dbghelp.dll it is trying to overwrite. Try closing the ProjectConfigurator and SetupAssistant and run the command again.

Hi @deependra_LY,

The reason the project fails to compile is because you have the build configuration set to debug_dedicated and the editor does not compile in this mode. You should use [Profile] game to compile your game.

Hi @deependra_LY,

The reason why you see a black screen in release mode is usually because:

  1. The shaders haven’t been compiled first
  2. Your game isn’t loading a level
    Here are detailed instructions for creating a release build:

http://docs.aws.amazon.com/lumberyard/latest/userguide/game-build-release.html