Dotnet, Server process exited without calling ProcessEnding(), exitCode(-2146232576)

My Environment
GameLiftServerSDKNet45
Version :4.0.0.0
Runtime Version : v4.0.30319

Console App(.NET Framework 4.7.2 )

Supersocket 1.6
WINDOWS_2012
GameLift Local Execute OK.

Custom Server Port : 50404
ProcessReady function’s param set port 50404.

Activation Fail
Code : SERVER_PROCESS_CRASHED
Message : Server process exited without calling ProcessEnding(), exitCode(-2146232576)

What kind of code is -2146232576?

i called Environment.Exit(0); After GameLiftServerAPI.ProcessEnding();

Has anyone ever experienced it?

Unexpected error codes are a pain. Looks like this maps to 0x80131700 as your Windows error code.

Does your application fail on launch? Or are you seeing it run for some time and then crash?

  • If you have logs, what do they show?
  • If you don’t have logs are you seeing successful calls to InitSDK/ProcessReady in your FleetEvents?
    • I would remote into an instance on the fleet and tail the logs to confirm behaviour

Are you installing any .Net runtimes in your install.bat? Did you confirm they are installed without issue?

I see your GameLift fleet is running on Windows 2012 Servers here, so unsure what version of .NET runtimes are installed by default but maybe not 4.7? Worth checking as this smells like mismatched .Net assemblies or the right runtime wasn’t correctly installed/is missing ie Troubleshooters don't work. Error code"0x80131700" - Microsoft Community (if the exit code maps correctly).

FYI: General error/exit code info (including links that will get you to the list of most error codes):

I have uploaded the .NET runtime to the fleet instance.
How to write install.bat to install .NET runtime “NDP472-KB4054530-x86-x64-AllOS-ENU”

in install.bat
just write “NDP472-KB4054530-x86-x64-AllOS-ENU.exe”
doesn’t working.

Look at the attached picture.
When installing manually, something like that pops up, and it’s probably the same thing.

How to write install.bat to install .NET runtime “NDP472-KB4054530-x86-x64-AllOS-ENU” ???

in install.bat :
C:\Game\NDP472-KB4054530-x86-x64-AllOS-ENU.exe /q /norestart /log “C:\Game\install.txt”

I tried the above command manually in install.bat. And it needed a reboot.

so I tried
in install.bat :

C:\Game\NDP472-KB4054530-x86-x64-AllOS-ENU.exe /q /norestart /log “C:\Game\install.txt”
shutdown.exe /s /t 00

and then Success!

By Success, did you get your fleet to go ACTIVE or just that you got the runtime installed?

Please let us know if you are still blocked.

Atctivated!
Thank you.

Now I need to upload it to Linux.