Dowload keeps dropping out

I am trying to download LY.

The setup file which is tiny, can’t even download without incident.

I tried many times, each time getting error message from MS( windows 10 pro) saying unspecified error 0x80072f7D .

I would get error, install would quit, so I"d quit the installer, rerun install exe and it would get a tad bit further, but I can’t do that indefinitely.I’m not really a sadist :wink:

So I wanted to make sure its not something odd on my system, so I downloaded, WITHOUT incident, the installer for unity3d, lastest 2018.2, and it installed fine,all 5gb of it, now its installing VS Community edition 2017, and the download went fine and the installation fine, no one single error.

I also , given my default engine atm is UE4, it also downloads a complete engine V and installs without incident.

GIven clearly its not on my end, what is going on with Amazon servers ?

I can’t be expected to sit here and babysit the installer, so for now its bye bye until I see a fix.

Thank You for a great engine but if I can’t even install it…

OK ty for whatever you did, as noted all other engine installs were going just fine, thankfully now it worked. Couldn’t be more overjoyed :wink:

TY LY