End of file unexpectedly reached before all data was read

Hello,

Today I was installing beta 1.12 and ran into an issue. The first time I opened the editor, it was fine and was in the process of importing all the assets for the starter map. Half way through this, my computer blue screened and screwed things up. Now, I can’t open the editor at all as it presents me with the below error.

I click “Ok” over and over…but the popup reappears.

There doesn’t appear to be a repair option with the installer. I’ve tried uninstalling and installing again but that made no difference.

How do I fix this?

Cheers

6191-2017-12-20-17-50-18-lumberyard-stuck-on-quotinitia.png

6192-2017-12-20-17-35-09-lumberyard.png

Resolved the issue by:

  1. Uninstalling LY
  2. In the previous install directory, delete all remaining files
  3. Install LY again
  4. Open the editor and allow the startup jobs to finish
    What I found interesting was that I let the editor go while it was running the Pending Jobs. When I came back to my computer, it appeared to have rebooted/crashed again. This time I received a slightly different error:

I was able to continue opening the editor and finish the Pending Jobs.

Unfortunately there were no errors in my Windows Event viewer under Application or System. If any of the developers would like me to provide specific logs, please let me know.

Thanks for the response. I tried your suggestion but it didn’t help unfortunately.

I did end up finding a solution which I just posted separately then.

Cheers

Sorry to hear about your blue screen and editor problem! Does the error popup also occur if you open just AssetProcessor.exe or does it only happen from Editor.exe? This would help me figure out if it’s an AssetProcessor issue.

If uninstalling and reinstalling didn’t work, it might also be worth resetting the registry…

To edit the Windows registry

  1. On your Windows desktop, click Start and type regedit in the search box.
  2. In the Registry Editor, go to HKEY_CURRENT_USER\Software\Amazon\Lumberyard.
  3. Right-click on Lumberyard folder icons and choose Delete. This deletes custom layout settings that you have for Lumberyard Editor.
    The default settings are restored the next time you start Lumberyard Editor.

I seem to be getting the same error. I added to gems Boids and Clouds I believe. Editor work fine before this. I get…end of file unexpectedly reached before all data was read… I removed the two gems and save the settings but I still get the message and If I hold enter it will keep cycling the ok button but just loop back to message. Tried this but didn’t fix the problem. I get this message right after the editor goes into “Initializing RenderD3D11…” on the startup Screen