Error! Cannot create the fleet. Reason: Current limit of fleets of 0 have been reached

Things were working fine last week, now whenever I try to create a fleet it gives this error:
Error! Cannot create the fleet. Reason: Current limit of fleets of 0 have been reached…

I have 0 fleets, and in the limits section it says I can have up to 20.
This seems to be happening to others as well. I only have 2 more days to finish my project so this is very unfortunate for me. :frowning:

5 Likes

Am getting the same error. Popped up 3 days ago after terminating a fleet and creating a new one. Was working absolutely fine until that last fleet creation attempt.

I contacted AWS support after upgrading my account to get access to technical support assistance, they’ve increased my Gamelift service limit for fleets but the error persists.

I also tested deploying a build and fleet on another region and even created a brand new account to test and the error persists. I’m guessing this is a general account / gamelift problem?

Also tried from within the CLI, no luck. same error.

Getting same error. Tried with two accounts and unfortunately no luck. I contacted the support and tried to increase my limits but it didn’t solved the error. Is this a general problem?

Same Error here. Since ~3 Days. Support just answered: “You are receiving the error message as the default value for EC2 Fleet for your account has not been updated to 20. To resolve the issue I have reached out to the service team, and they are currently working on this.”. But it worked for month before, and since other accounts are affected too, this might be a general problem.

1 Like

They say this but increasing the limit doesnt fix the problem. I can now personally confirm this is a general issue with the gamelift services and all accounts connected to it.

I’ve created two seperate, totally new accounts, also one from a different region, and the issue persists. A little trasparency and acknowledgment from AWS would be appreciate to help debug the issue. Right now they are sweeping it under the rug and making me believe my account is the problem.

In the meantime I have a game community that is on hold and to which I must explain the current happenstance.

Getting the same error. We’ve started getting this around when we started using Organization accounts to manage multiple development environments for different developers, I wonder if it’s related somehow.

Creating new fleets has been impossible for many accounts for a few days now, an update from the development team would be nice.

1 Like

Looks like it’s about the free-tier eligible accounts and machines. I tried to create a new fleet with c5.large with an organization account that doesn’t have free-tier eligibility and it worked.

Anyone has updates on this?

Glad it was sorted for you. That did not work for me unfortunetly. :confused:
But what did work was a week of pressuring AWS Support. Finally unlocked my restrcition! :partying_face:

1 Like

@cyrusjameskhan Can you tell me how you rectify that error ,i got struck in this for hours,can you help me

You have to send a message to AWS support. Can take a few days to a week but eventually they’ll respond. Really a bummer of an error.

Hi folks, if you run into this error, please follow these steps to get your limits increased.

  1. Go to https://us-east-1.console.aws.amazon.com/support/home?region=us-east-1#/case/create
  2. Select “Service Limit Increase”
  3. In “Limit type”, select “GameLift”
  4. In “Requests”, select your region. If you need multiple regions, select “Add another request” and select more regions
  5. In “Case description”, specify the following information
    • Instance type
    • Desired limit
  6. Submit
1 Like

Thank you, finally this works!

Regards, John, web-designer, WorkTime