Error on Creating new Project

does anyone know why this keep happening everytime i try to create new project? and is there anyway how to fix it?

  "C:\Amazon\Lumberyard\1.12.0.1\dev\lmbr_waf.bat" build_win_x64_vs2015_profile --enabled-game-projects=AfterRain -p AfterRain
[WAF] Engine Root: C:\Amazon\Lumberyard\1.12.0.1\dev\
[WAF] Executing 'build_win_x64_vs2015_profile' in 'c:\Amazon\Lumberyard\1.12.0.1\dev\BinTemp\win_x64_vs2015_profile'
[WARN] Removing target platform win_x64_vs2013 due to "Visual Studio 2013" not checked in Setup Assistant.
[WARN] Removing target platform android_armv7_clang due to "Compile For Android" not checked in Setup Assistant.
[WARN] Removing target platform android_armv8_clang due to "Compile For Android" not checked in Setup Assistant.
[WARN] Game project 'StarterGame' configured in bootstrap.cfg is the enabled game for this build. In order to run or debug for the game 'AfterRain', they need to be set in bootstrap.cfg under the 'sys_game_folder' entry accordingly
[WARNING] Incredibuild disabled by build option
[WARNING] 'libpath' value 'c:\Amazon\Lumberyard\1.12.0.1\dev\Code\SDKs\LibTomCrypt\lib\ios' defined in TaskGenerator "AfterRainIOSLauncher" does not exist
[WARNING] 'libpath' value 'c:\Amazon\Lumberyard\1.12.0.1\dev\Code\SDKs\LibTomMath\lib\ios' defined in TaskGenerator "AfterRainIOSLauncher" does not exist
[WARNING] 'libpath' value 'c:\Amazon\Lumberyard\1.12.0.1\dev\Code\SDKs\FreeType2\ios\lib' defined in TaskGenerator "AfterRainIOSLauncher" does not exist
unable to find QT
unable to find QT
Traceback (most recent call last):
File "C:\Amazon\Lumberyard\1.12.0.1\dev\Tools\build\waf-1.7.13\waflib\Scripting.py", line 226, in waf_entry_point
run_commands()
File "C:\Amazon\Lumberyard\1.12.0.1\dev\Tools\build\waf-1.7.13\waflib\Scripting.py", line 342, in run_commands
ctx = run_command(cmd_name)
File "C:\Amazon\Lumberyard\1.12.0.1\dev\Tools\build\waf-1.7.13\waflib\Scripting.py", line 319, in run_command
ctx.execute()
File ".\Tools\build\waf-1.7.13\lmbrwaflib\msvs.py", line 1926, in override_build_state
old(ctx)
File "c:\Amazon\Lumberyard\1.12.0.1\dev\wscript", line 317, in execute
return execute_method(self)
File "C:\Amazon\Lumberyard\1.12.0.1\dev\Tools\build\waf-1.7.13\waflib\Scripting.py", line 696, in execute
return execute_method(self)
File "C:\Amazon\Lumberyard\1.12.0.1\dev\Tools\build\waf-1.7.13\waflib\Build.py", line 254, in execute
self.execute_build()
File "C:\Amazon\Lumberyard\1.12.0.1\dev\Tools\build\waf-1.7.13\waflib\Build.py", line 277, in execute_build
self.compile()
File "C:\Amazon\Lumberyard\1.12.0.1\dev\Tools\build\waf-1.7.13\waflib\Build.py", line 370, in compile
self.producer.start()
File "C:\Amazon\Lumberyard\1.12.0.1\dev\Tools\build\waf-1.7.13\waflib\Runner.py", line 303, in start
self.refill_task_list()
File "C:\Amazon\Lumberyard\1.12.0.1\dev\Tools\build\waf-1.7.13\waflib\Runner.py", line 209, in refill_task_list
self.add_outstanding_tasks(next(self.biter))
File "C:\Amazon\Lumberyard\1.12.0.1\dev\Tools\build\waf-1.7.13\waflib\Build.py", line 818, in get_build_iterator
self.post_group()
File "C:\Amazon\Lumberyard\1.12.0.1\dev\Tools\build\waf-1.7.13\waflib\Build.py", line 789, in post_group
f()
File "C:\Amazon\Lumberyard\1.12.0.1\dev\Tools\build\waf-1.7.13\waflib\TaskGen.py", line 218, in post
v()
File ".\Tools\build\waf-1.7.13\lmbrwaflib\cry_utils.py", line 671, in add_compiler_dependency
if os.path.isabs( self.env['CC'] ):
File "C:\Amazon\Lumberyard\1.12.0.1\dev\Tools\Python\2.7.12\windows\lib\ntpath.py", line 59, in isabs
return s != '' and s[:1] in '/\\'
TypeError: 'in <string>' requires string as left operand, not list
Process failed with return code: 1

Hey @shandy6661 – sorry for the troubles. Did you happen to run configure command before this (build command)?

hi @Amonster_LMBR thanks for the respond
i think the configure is fine

the only problematic thing is here

its keep happening anytime i try to create new project.
and also i have tried to create new Project through Command-Line (CMD) and its ends up the same

well, i just hope it can be fixed somehow without downloading entire Engine in next update because the internet connection is kinda struglling here :frowning:

thanks @Amonster_LMBR i hope to hear from you as soon as possible

any Luck so far? @Amonster_LMBR

if the only solution is wait for the next update then its fine, i can use current StarterGame For Prototype some entitie / Slices, but tell me if it will be fine if i moved them into Different Project later?

Got it – let me get some answers from my peers to assist with this further. I’m very sorry for the experience. Hang tight –

hey @shandy6661 – sorry for the delays, we’re having to dive deep into this topic some more to get a clear answer on this issue. I’ll keep you posted as much as possible. Again, apologies on the delays.

all good @Amonster_LMBR problem is solved since i switch to VS2013, but you and LY Dev team might want it fixed still as all users might not be used VS2013.
thanks for responding by the way :slight_smile:

I ran into this issue today after installing lumberyard 1.19. I was able to fix it by changing the Python version from 2.7.12 to 2.7.13 in the …/dev/Tools/Python/python.cmd file.