EXPLICIT Tutorial Needed

Hi guys. I’m REALLY frustrated with getting a sound into the game. I set up Wwise, followed the instructions in the tutorial, exported the sound bank, but I can’t seem to get Lumberyard to see my new bank of sounds AT ALL. The only one I can get it to see is the default bank in SampleProjects/Sounds, and if I REPLACE that bank with a new one, it won’t acknowledge the new bank is there (plus all the default bank stuff is gone).

So for idiots like myself, please explain in excruciating detail exactly what I need to do in order to successfully export a new Wwise sound/bank/whatever into the right folder it needs to be in. (Assume that I’ve got a game folder within the level folder of the SampleProjects folder.) I have to say, this is one element of the engine that I really hate. Something as simple as “play a sound” shouldn’t require this much backflipping through so many windows.

@Nealiios

I’ve been having the same problem. Although I don’t have it working completely yet I was able to finally get the Audio Controls Editor to see my sound bank.

  1. This doc shows you how to use Wwise with Cryengine and since they stress the importance of ensuring proper directory structure I replicated it by placing my sound bank in the directories they’ve listed: http://docs.cryengine.com/display/SDKDOC2/1±+First+Steps+with+the+Audio+Translation+Layer+%28ATL%29+and+Wwise
  2. For me that entailed adding a new directory under “Sounds” called “wwise_project”
  3. I then copy-pasted the directory structure from my level into this new “wwise_project” directory (to find the correct directory in my level I searched for the “Actor-Mixer Hierarchy” folder and copied it along with all of its peers).
  4. Now when I go to the Audio Control Editor the Wwise Controls for my sound is there! I dragged it into the Inspector area and am now going to work on the Flow Graph to see if this will work.
    I spent so much time just trying to locate where the Audio Controls Editor was looking for the sound bank. Hopefully this is the right approach (until a better method is available).
  • Drew

Hi @Nealiios

As drew mentions, the directory locations are very precise. There is some documentation at the bottom of this page regarding the locations for audio-related data:

http://docs.aws.amazon.com/lumberyard/latest/userguide/audio-atl-editor.html

We are aware of the problems people are facing getting started with audio, and fortunately we are getting an Audio Tutorial ready for users, along with an example Wwise LTX project to use.

Still at war with this system. I’ve tried doing what the tutorials said, I’ve tried doing what the Crytek tutorials said, and I’m coming up with a big stinking GOOSE EGG.

The only trick that’s worked for me – and it is a very restrictive trick at that – is that I’ve taken the soundbank that came with Amazon Lumberyard (in Sample Projects/Sounds/wwise), I’ve replaced it with my soundbank, renamed my sounds to match those of the pre-existing audio controls (i.e. the cannon_shot), and I created new events to fire my sounds. Now when I get back into Lumberyard, I can open up the Audio Controls and fire the pre-existing event to get my sound, but there’s absolutely NO sign of any new sounds or the events I’ve created for them anywhere in the Audio Controls panel on ANY side, despite the fact that I know it’s looking at MY soundbank because I replaced the original cannon_shot sound with my own sound.

Referring to Drew’s suggestion, I’m guessing that outside of the Sounds/wwise directory there might be another folder that the soundbank is supposed to point to, but in the existing Sample Project folder, there is no wwise_project folder anywhere that I can find, so there’s no solid example there that explains how this is supposed to work under normal circumstances. This is one aspect of the engine that I have to admit right now is seriously pissing me off.

@Nealiios the only way I was able to find the wwise_project folder was by searching for “actor-mixer hierarchy” which pointed me here: lumberyard / dev / SamplesProject / Sounds / wwise_project

I copied everything in this directory and pasted it into the new wwise_project folder that I created per my instructions above.

Okay, so here’s my problem. The folder you’re mentioning DOES NOT EXIST in my installation of Lumberyard, either in 1.0 or 1.1. Here are the installation files. There’s no wwise_project to be found here.

ARRRGH. I can’t attach the third image of the contents of the wwise folder. In any case, the only stuff inside the wwise folder are two files, Content.bnk and Init.bnk. Now as far as I can tell, these files must be using sorcery if they’re supposed to be pointing to a wwise_project folder 'cause it just doesn’t exist on my machine, and they play just fine without that folder there, so I don’t get how they even work in the first place.

Hey @zebra_xray
Okay, so I did all of what you suggested, but still not quite getting to where I need to be. Copied everything over to where you said, created a SFX in WWise, created a Play event for it, added the Default Work Unit to the Soundbank, saved it, and generated a Soundbank called BAKRemastered. You can see it here:

Once that was done, I hopped over to Lumberyard and fired up the Audio Controls. On loading, I can see the name of the soundbank – BAKRemastered – over on the right hand side, but there’s no sign of the Play_chest_tumbler event that I created for the bank, just the name of the bank itself. I tried dragging my new bank over the left side and adding it as a preload, then I reloaded the Audio, but that made no difference. No sign of any triggers. (I remain mystified as well how the pre-existing Content.bnk can evidently access sounds without any obvious wwise_project to point to, so I’m assuming there’s something baked into an entity or a lua file somewhere that’s giving it what it needs).

One thing that I wanted to be clear on, and maybe this is the source of the difficulty, was something you said above: “Verify that the path to the .wproj file is now: \SamplesProject\Sounds\wwise_project<YourProjectName>.wproj” Now by verify, do you just mean make sure that the BAKRemastered.wproj file is inside \wwise_project\ or did you mean that I need to modify a pathname in a file somewhere? And if so, where all do I need to modify it?

I feel like I’m vaguely in the neighborhood here, I just can’t find the right house.

Hi @Nealiios

Please try the following:

  • Close Wwise LTX and the Editor.

  • Move the folder containing your Wwise LTX project to \SamplesProject\Sounds\

  • Rename the project folder to “wwise_project”.

  • Verify that the path to the .wproj file is now: \SamplesProject\Sounds\wwise_project<YourProjectName>.wproj

The above steps are what allows the Audio Controls Editor to locate your project data. As you add new events, RTPCs, etc the Audio Controls Editor will detect changes you’ve made to your Wwise LTX project and display them in the “Wwise Controls” pane.

Continuing…

  • Launch Wwise LTX and open your project from the new location.

  • Press Shift+K to open your Project Settings.

  • Click on the “SoundBanks” tab.

  • In the “SoundBank Paths” section, set the “SoundBank Folder” setting to “…\wwise”. You can do this with the “…” browse button or by double-clicking the item and selecting \SamplesProject\Sounds\wwise. In the end it should display “…\wwise”, then click Ok.

The above steps are done in order to generate your sound banks to the correct location for Lumberyard to pick them up.

Now you can launch the Editor and see if you events now show up in the Audio Controls Editor. Just so you know, you can be editing your Wwise LTX project while having the Editor open. Whenever you save your Wwise project, you should see the “Wwise Controls” pane update to reflect the changes. However, sometimes you need to Generate your banks again. After doing so, go to the main Editor window and click Audio->Refresh Audio from the file menu. That will issue a dump and reload of all audio data.

If you’ve got this far, you should be able to continue creating ATL controls from your Wwise controls and integrating them into your game.

Hope this helps!

Hi Nealiios,

Ever managed to fix this issue? I seem to have the exact same issue as you had… Please let me know. Thanks.

Hey @GVA1994, since this thread is so old, it might be better to start a new thread with the exact issues you are running in to.