Failed to load Gem DLL

After adding the Woodland Assets and also the Legacy assets into the gems files and appropriating the correct paths to each so following the tutorials, I come up with this error:

Failed to load Gem DLL Gem.Boids.97e596870cf645e184e43d5a5ccda857.v0.1.0.dll

Which is a fatal error and causes the editor to crash.

I’ve tried both to install all the necessary and required SDK’s and recompiling via VS and the command prompt’s lmbr_waf.exe configure + lmbr_waf.exe build_win_x64_profile -p all --progress but to no avail.

Are there any other steps to try before I call it quits?

Yes, the tutorial said for the Legacy pack I needed the GameSDK selected as default for it to work.

It is enabled and has been before recompiling as shown here:

https://i.gyazo.com/d48e5122cc1fe3842e25681147221270.png

I can try a new project if that’s what I need to do.

I run it from the Lumberyardlauncher, after configuring the project and seeing I have everything required.

Bootstrap.cfg are as follows:

– any of the settings in this file can be prefixed with a platform name
– android, ios, osx, linux, windows, xbone, ps4
– or left unprefixed to set all. The rules apply in the order they’re declared
sys_game_folder = GameSDK
– remote_filesystem - enable Virtual File System (VFS)
remote_filesystem = 0
– What type of assets are we going to load?
– We need to know this before we establish VFS because different platform assets
– are stored in different root folders in the cache. These correspond to the names
– In the asset processor config file. This value also controls what config file is read
– when you read system_xxxx_xxxx.cfg (for example, system_windows_pc.cfg or system_android_es3.cfg)
assets = pc
– by default, pc assets (in the ‘pc’ folder) are used, with RC being fed ‘pc’ as the platform
android_assets = es3
– if you change the renderer on android to be OpenGL you may need to change this.
ios_assets = ios
– ip and port of the asset processor. Only if you need to change defaults
– remote_ip=127.0.0.1
– remote_port=45643
– do we connect to the asset processor, or do we listen for its (reverse) connection?
connect_to_remote = 1
– do we pause startup of the game and wait for connection to be established
– or do we allow it to continue in the background without waiting?
wait_for_connect = 0
– android and IOS over USB port forwarding may need to listen instead of connect
– android_connect_to_remote=0
– ios_connect_to_remote=0

And WAF user_settings.options are as follows:

[Game Projects]
enabled_game_projects = hi
[Incredibuild Options]
use_incredibuild = False
use_incredibuild_win = False
use_incredibuild_durango = False
use_incredibuild_orbis = False
use_incredibuild_android = False
incredibuild_max_cores = 16
[Visual Studio Project Generator]
generate_vs_projects_automatically = True
visual_studio_solution_name = LumberyardSDK
visual_studio_solution_folder = Solutions
specs_to_include_in_project_generation = all, game_and_engine, resource_compiler
msvs_version = 12
[Durango Options]
deploy_durango = True
deploy_durango_kits = durango_paks = False
[Build Options]
version = 1.0.0.0
generate_debug_info = True
generate_map_file = False
use_precompiled_header = True
use_uber_files = False
uber_file_size = 307200
use_static_code_analyzer = False
max_parallel_link = 2
gems_optional = False
use_debug_code_generator = False
[Output Folder]
out_folder_win64 = Bin64
out_folder_durango = BinDurango
out_folder_mac64 = BinMac64
out_folder_orbis = BinOrbis
out_folder_ios = BinIos
out_folder_linux32_gcc = BinLinux32gcc
out_folder_linux64_gcc = BinLinux64gcc
out_folder_linux32_clang = BinLinux32clang
out_folder_linux64_clang = BinLinux64clang
out_folder_android_armv7 = BinAndroid
[Mac Project Generator]
generate_mac_projects_automatically = True
mac_project_name = LumberyardSDK
mac_project_folder = Solutions
default_project_to_build = SamplesProject,

[Misc Options]
max_cores = 8
ly_launcher_param
= --none --enablecapability compilegame --enablecapability compileengine --enablecapability compilesandbox --no-modify-environment
ly_launcher_third_party_override = [Android Project Generator]
generate_android_projects_automatically = False
android_projects_folder = Solutions/android
default_project_to_build = SamplesProject, [iOS Project Generator]
generate_ios_projects_automatically = True
ios_project_name = LumberyardiOSSDK
ios_project_folder = Solutions
default_project_to_build = SamplesProject, [Orbis Options]
deploy_orbis_clean_target = True
deploy_orbis = True
deploy_orbis_executable = True
deploy_orbis_kits = orbis_paks = False

@Wolf

Is there a “Gem.Boids.97e596870cf645e184e43d5a5ccda857.v0.1.0.dll” in your Bin64 folder? If there is not, then you should use the Project Configurator to make sure the correct project is selected – Gems only build if they are being used by one of the currently selected projects.

@Wolf

Which executable are you trying to run when you get the error; could you post the log from that program?

What settings do you have in your bootstrap.cfg and “WAF\user_settings.options”?

(Creating a completely new project shouldn’t be required, but it is hard to figure out what exactly is wrong from the forum posts so you may find another approach will work better)

I’m getting the same exact error and the dll file is not located anywhere in my Lumberyard folder. I’m configuring a pristine coding environment as part of the process of moving to a new PC and I haven’t created any new projects or changed my default project from SamplesProject.

I’ve done trial-and-error on each of the non-default gems and found that enabling any of the following results in a similar “Failed to load Gem DLL Gem....dll” error message that results in the editor crashing completely:

  • Boids
  • Game Effect System
  • Lightning Arc (requires the Game Effect System)
  • Process Life Management
  • Snow
  • Tornadoes
    All other gems are currently enabled and I can run the editor normally, but as soon as I enable any one of the above gems, I get the fata error message pointing to the first gem from the list that it hits. I have made sure that the Asset Processor is processing what appears to be all assets for each gem, but it doesn’t make any of these work.

Do I need to run lmbr_waf with some specific switches to get these to work?