Failed to load shader '<Default>'! error

This started happening after updating to 1.25 from 1.24.

Any time I try to edit and save a material in the Material Editor it throws these errors:

[Error] [SHADERS] Failed to load shader “<Default>”!
[Warning] WARN: Shader “<Default>.cfx” doesn’t exist (used in material “somematerial”)

Within a few minutes of using the Material Editor, Lumberyard goes unresponsive indefinitely. Some of the steps I’ve tried to remedy this is completely removing then reinstalling Lumberyard, and even tried it on a different computer. Even on a pristine Lumberyard install and only building the Starter Game, I still get that error.

It seems like I’m the only one experiencing this (I’ve asked about this in Discord as well), but I’m getting the same issue on pristine Lumberyard installs on two different machines.

My install and build process is this:

  1. Download lumberyard installer, install to c:\
  2. Run the Setup Assistant with the following selected:
  3. Install software
  4. Required SDK’s are all installed/green check marked. None of the optional SDK’s are installed
  5. In Project Configurator the Starter Game is set to default, and I leave the default gems selected
  6. I run:

lmbr_waf configure
lmbr_waf build_win_x64_vs2019_profile -p all

Is there anything I am missing? This issue has been killing me for the last couple of weeks so any help or suggestions would be greatly appreciated!

Honestly I have never seen this issue before, I feel there is something wrong with you download, have you tried a reinstall of LY? That is all I can think of that could fix this, because your steps is the same as I do for my own projects and it works perfect. Sorry I cannot help more, this is just a strange thing you came across.

So, I just dug up and reimaged an old laptop. Downloaded and installed Lumberyard (fresh Windows 10 install), built the Starter Game, and ran into the same issues with the default shader and Material Editor instability.

I should point out that when I first installed 1.25, within a couple days of its release, I didn’t experience any of these issues. Later I uninstalled it on that machine for a different reason, then when I reinstalled it, I started having those issues (probably should have pointed this out to begin with). And of course now again with installing it on the laptop I’m seeing the issues there as well.

I feel like something definitely changed. Either with the installer or the source files it installs.

Is there anyone who has downloaded/installed 1.25 within the last week, or is willing to download it now and test my theory out, that can confirm the same experience?

I just installed 1.25 a day ago and do not get this issue? So it does not seem to be a bug with the installer as of 8/29/2020. Sorry to here this is happening, I hope a dev can help you out with this error and resolve it.

Hmm, okay, thank you for getting back and letting me know that.

I’m at a complete loss. It makes no sense to me that, on a different freshly reimaged system, with a fresh Lumberyard install, I would get the same error.

I know that I have to login to Amazon in order to use the Lumberyard Editor. I wonder if some configurations get saved with Amazon that get restored when I first login to use the editor? Maybe I did some configuration that broke things and it keeps getting downloaded from Amazon. That’s about all I can think of because I’ve checked over and over again that there’s nothing off with my process for installing and building Lumberyard (been using Lumberyard since 1.18 and always upgraded as soon the next release came out and never had an issue like this). Maybe I’m missing something though…

Guess I’ll just hope that 1.26 fixes the issue whenever that comes out

Yea I guess there is a hope, you could try to make another account just to check if that could be the issue, but maybe you are not getting a perfect install. One person kept getting a Hash error which no dev knew the issue of it, but when he installed on a different internet (he was using a usb wifi transmitter) his install was perfect. That is my only other guess. 1.26 seems to be coming out on late September into October just a FYI. They release a usual update every 2.5 - 3 months.