FBX Settings Motion Range Problems

When trying to specify the motion range of an animation in FBX Settings, the importer thinks there are only 81 frames of animation when in reality there are over 2000 frames. When applying this motion to the actor, I can see that the 81 frames that the importer has chosen to use are the last 80 frames in the animation. This same FBX has been used without issue in other engines.

These are the steps I followed:

-Right click the FBX in the Asset Browser -> Edit Settings

-In the Motions tab, Add Modifier -> Motion Range

-The range is entered, then Update is clicked, which brings up the error: pcE: 1> 0:02 Start frame 300 is greater or equal than the actual number of frames 81 in animation

Any help would be appreciated, thanks!

Hi @NateOrr - multiple animations are supported, but the frame ranges must be set up manually when doing Edit Settings of the FBX file in the Asset Browser. In the Asset Browser, right-click on the file and select Edit Settings. Go to the Motions tab, and for your first motion, (re)name it what you like and press the “Add Modifier” button and select “Motion range”. Set the desired frame range for your first motion. Then press the “Add another motion” button at the top of the Motions tab and repeat this procedure, to add and define as many motions as you like from your FBX file.

If you have multiple characters in a single animation file, you will need to define different Actors in the Actors tab, and then make sure you have the correct root joint selected in the “Select root bone” field of the Motions for that character.

Please note also that any FBX file processed by the engine will have a .ASSETINFO file saved alongside it (same name as the FBX file but with the .ASSETINFO suffix) so that any information like the creation of multiple separate animations from a single FBX will be saved with the FBX - something to note if you are using any form of source control on your project.

I am not sure how you would expect FBX to “know” about your separate animations from your source file - is there a method in particular that you are using in your source file that you would expect to be translated into the FBX format and read by the game engine? Thank you for any more information you can give us - we are always trying to understand the needs of our customers and how to make Lumberyard better!

Hi @NateOrr - we will take a look at your issue - could you please let us know a little more information -

  1. Which version of the engine are you using?

  2. What software was used to generate the FBX files?

  3. Which version of FBX was used, and whether the FBX is ASCII or binary

  4. Did you bake animation onto your Actor skeleton, or is your animation still on the rig?

Thanks!

I’m using version 1.12.0.1 Build 532502.

I’ve tried now with several different FBX files exported from both Blender and Max, and various versions of FBX. 7.4 binary and 6.1 ASCII are two versions I can verify, there may be others mixed in. All FBX files I’ve tried to import have the same issues:

  1. If the FBX file contains multiple separate animations only a single animation is picked up by Lumberyard.

  2. If the FBX file contains a single track with the animations placed in at specific frame ranges, only a subset of the total frames is pulled out.

Are multiple animations in an FBX just not supported?

Thanks for the reply. I don’t expect the importer to know anything about the animations, like I described in the original post I’ve already done exactly as you said. And like I said, the FBX Settings throws an error saying there are only 81 frames available in the FBX, when there are actually a few thousand frames. I’ve tried with about a dozen different FBX files and it’s always the same.

I can import these same FBX files into Unity, and set up all of the animations based on frame ranges without issue.

Sorry I’m not sure if the original file I’ve tried has it baked. When I exported a couple FBX files from Blender I had the baked animation box checked tho, and these behaved the same way as my original file with the FBX Settings. Not sure if it’s any help but I uploaded one of the FBX files I was testing with, which has 15 animations.

6351-spider.zip (831 KB)spider.zip

Thanks @NateOrr for the clarification - sorry if I misunderstood. We will look into the issue as you have described. If you can also still answer #4 from above - have you baked the animation onto your root character skeleton (either manually or using the bake function during FBX creation) or are the animation keyframes on the character rig controls? Thanks for any more info - we will look into this issue and let you know what we find.

Hi @NateOrr - that will be helpful, thank you for sharing the FBX file.

Hi @Castor, thanks for getting back again. I’m not really sure how else to word this, I’m not having any issues with the rig or skeleton. For all the FBX files I’ve tried to load they all look visually correct, and what little animation does get loaded in looks exactly how it should. The problem is the FBX importer is only loading in a small fraction of the animation frames.

6340-error.png

For example, the FBX used in the images above. There are 39 seconds of animation in that file. Both Unity and Open 3D Model Viewer have no issues loading and splitting the animations, but the FBX Importer in Lumberyard thinks there are only 34 frames.

The spider FBX I attached has the animations already split up in the FBX instead of using a single track for all the anims, and the result is still the same. In Lumberyard It’s not possible to load an FBX that contains multiple animations and use the Motion Range or anything else with the FBX Settings to split them up.

We’ll just work around this and export one FBX per animation.

Hi @NateOrr - when I derive the Actor from your FBX and set it up in the Animation Editor, I can see that the skeleton seems to have some scaling and orientation issues. It appears smaller and behind the mesh, and rotated, which suggests it might have some scale and rotation values on the root joints or character controls. You would have to go back to the rig and skeleton in the source file to determine where the issue lies.

6329-spider-skeleton.jpg

I can see some animation, but it would be difficult to debug the animation before you determine what the issue is with the initial character setup.

Our documentation on basic character setup is still in transition from the legacy system, and will updated soon.

Hi @NateOrr - on further examination of your FBX file, it is clear that you are using “takes”. You have used a system to create the FBX that utilizes multi-takes, so that multiple animation takes can be written to a single animation file. This is what I mentioned above about FBX “knowing” about your separate animations - Motion Builder can write multiple animation takes into a single file, as can some plugins for software such as Maya, 3ds Max and Blender. Unity is also aware of “takes” within a single FBX file. However, currently the Lumberyard FBX pipeline does not parse takes, so you would have to eliminate takes from your animation creation pipeline in order for them to work with Lumberyard. Hope this helps.

Also - side note - it looks like your original animation file was created at 24 FPS, while the Lumberyard game engine runs at 30 FPS. You may want to adjust your source files to be 30 FPS and recreate your FBX files from those so that you have WYSIWYG between source and game files.

File Version: 7.4.0
File Creator: Blender (stable FBX IO) - 2.76 (sub 0) - 3.6.2
File Custom writer: No
File Creation Time: 2016/1/11 23:51:17
File Axis Direction: Y-up (RH)
File Units: Centimeters
System Axis Direction: Y-up
System Units: Centimeters
System frame rate: 30 ***Warning: Frame rates do not match***
File frame rate: 24
File content: 51 Elements, 5 Materials, 6 Textures

Hey @NateOrr – Based on @Castor’s answer, I’ve modified the selected solution to this particular thread/question. Thanks for your patience and awesomeness!

Cheers :slight_smile:

@Castor Thanks for following up and working through this with me. I did manage to get this all working from Blender, by exporting the animation with the NLA editor instead of as actions.

No problem @NateOrr - happy to help, glad we got to the bottom of it!

Does anyone know if amazon haves plans to add “takes” to the FBX importer? took me forever to figure out this is why my other animations were not loading in lol.