FLEET_INITIALIZATION_FAILED - GameLift

Hello,
I am trying to learn and explore AWS GameLift service, I don’t have any gaming domain background, I went through the GameLift Service docs and trying to learn this new technology/service.

I am following this workshop , I am facing issue while creating the fleet.Please refer to the screenshot below :

Screenshot from 2021-08-04 10-43-45

It will be great if someone could help me to understand the root cause of the issue and solve it.

Hi @Shivkumar_Mallesappa

Some things to try:

  1. Have you tried running the server process executable locally? If not, try following this guide (Testing Your Integration - Amazon GameLift) to do so. If the game is able to successfully heartbeat in GameLiftLocal and not crash, then proceed to the next steps.
  2. Check your install script (install.sh/install.bat) to see if there are any syntax errors. You can try running the install script on an linux/windows machine locally first, or spin up a small ec2 instance to do so. It’s likely that your installer failed. We are working on providing an error log in the fleet event when that happens, so hopefully debugging this will be easier in the future.

Hi James,
Thanks for your suggestions, let me try this and get back to you.

Hi James,
I tried to install , install.bat on my Windows machine, it is not doing anything.
I opened the file and there is only line in the file vc_redist.x64.exe /q , how can I detect the root cause for this , since I have downloaded everything from the workshop only.
I will be very thankful if you could help me out here.

It’s likely due to vc_redist.86.exe not being found in the windows PATH environment variable.

According to a later step in the lab on fleet creation, it says: “Check whether there are files GomokuServer.exe, aws-cpp-sdk-*.dll, config.ini, install.bat, aws-cpp-sdk-gamelift-server.dll exist on given folder bin/GomokuServer. Check whether vc_redist.x86.exe exists.” See: Creating Game Server Build & Fleet :: Start Full Stack Game with GameLift

The project’s README tells you to get it: GitHub - aws-samples/aws-gamelift-sample: A simple full-stack game sample using GameLift and AWS services.. Though it defaults to Korean locale. Here is the English locale: Download Visual C++ Redistributable for Visual Studio 2015 from Official Microsoft Download Center

Once you download vc_redist.x86.exe, make sure it is runnable, and put it in the same level in directory as the install.bat. However, if that doesn’t work, maybe try using the absolute path, i.e. C:\Games\<your_build_dir>\vc_redist.86.exe /q

Hey James,
Thank you for your inputs and help, this worked, fleet is in Active State.

@Shivkumar_Mallesappa

Great! Please let us know if you run into have any other issues.