FPS cap for the Editor?

Is there some way to cap FPS for the editor? I have a noisey GPU and don’t need the editor running at 200 FPS. It doesn’t obey the nvidia control panel vsync setting.

Good find. That is exactly it.

I may have found the answer. Console command sys_MaxFPS

HI,

sys_MaxFPS apparently doesn’t do anything to cap the editor. I tried a few values 30, 60 and 144, it doesn’t seems change anything. I’m using 1.11.1.0 and the console shows:


sys_maxfps=30
sys_MaxFPS=30 [ ]

The editor still pushing an empty level to highest FPS possible despite sys_maxfps had been changed. GPU runs 100% all the time, which is too noisy and hot.

Can you check with the team @Binky_LMBR?

Checking with the team on this @AwieWings – apologies for the troubles.

@Amonster_LMBR strangely, this actually works in lumbertank sample game. Apparently it doesn’t work only in a newly created project.

That’s odd! Thanks for keeping us posted on this :D. I’ve sent this note to the team for further action

Good afternoon,
Ensure that you have vsync turned OFF in the editor, otherwise the “sys_maxFPS” won’t work:

vsync on:

5893-vsync-on.jpg

vsync off:

Hope this helps,

-MajorBliss

Is there a way to set this by default? When my framerate goes above 200 fps, my mouse look becomes choppy and unusable in the editor. In game, framerate is capped at 60 fps and runs smooth as glass.

As stated here you can modify default values for these variables in system.cfg and user.cfg files.

I modified my C:\Amazon\Lumberyard\1.24.1.0\dev\Engine\Config\user.cfg like this and it worked:

–This file allows users to override the system defaults for cvars
r_VSync=0
sys_MaxFPS=60

I think this is sort of global default values and can be overridden on per project basis.

1 Like