GameLift Suck at PotentialMatchCreated with Flexmatch

Hi Gamelift Team

I am integrating with flexmatch but when i try to make matchmaking with 2 clients but the gamelift suck at PotentialMatchCreated status and client could not receive matchmaking information like ipaddress,

So could you please guide me how can i see gamelift log to see what’s root cause for this problem

this is my matchmaking event log:
{‘Records’: [{‘EventSource’: ‘aws:sns’, ‘EventVersion’: ‘1.0’, ‘EventSubscriptionArn’: ‘arn:aws:sns:ap-northeast-2:427839003081:gomoku-match-topic:e0293ea8-88c0-4320-a1b8-24925381ae4d’, ‘Sns’: {‘Type’: ‘Notification’, ‘MessageId’: ‘3df912d6-b2c9-560d-8370-489886a73980’, ‘TopicArn’: ‘arn:aws:sns:ap-northeast-2:427839003081:gomoku-match-topic’, ‘Subject’: None, ‘Message’: ‘{“version”:“0”,“id”:“55772a34-1291-4999-9e32-a8e9db731a31”,“detail-type”:“GameLift Matchmaking Event”,“source”:“aws.gamelift”,“account”:“427839003081”,“time”:“2022-01-04T11:40:30.564Z”,“region”:“ap-northeast-2”,“resources”:[“arn:aws:gamelift:ap-northeast-2:427839003081:matchmakingconfiguration/ZombieMatchConfig”],“detail”:{“tickets”:[{“ticketId”:“c084c22e-f403-4eb5-9216-097d4b03b82e”,“startTime”:“2022-01-04T11:40:10.327Z”,“players”:[{“playerId”:“phuctest”,“team”:“blue”}]},{“ticketId”:“ac668198-d2d2-4b33-a603-04597f4da09d”,“startTime”:“2022-01-04T11:40:30.347Z”,“players”:[{“playerId”:“phuc4”,“team”:“red”}]}],“ruleEvaluationMetrics”:[{“ruleName”:“EqualTeamSizes”,“passedCount”:3,“failedCount”:0},{“ruleName”:“FairTeamSkill”,“passedCount”:3,“failedCount”:0}],“acceptanceRequired”:false,“type”:“PotentialMatchCreated”,“gameSessionInfo”:{“players”:[{“playerId”:“phuctest”,“team”:“blue”},{“playerId”:“phuc4”,“team”:“red”}]},“matchId”:“e69df7fa-43b2-40c2-93b8-c1dfcbe6ce73”}}’, ‘Timestamp’: ‘2022-01-04T11:40:30.574Z’, ‘SignatureVersion’: ‘1’, ‘Signature’: ‘ogOCoN7sIqwkTC9gynzi1Y55JoKqjkyJw+wd3ygO174Bjj0ic6ddqzJEiV42/sFqXVKytDLSDr0wGs831FbFJDaOd0EPkpq0Kvsr+kaFtbVFZlB/sNLqL7Q1cMK6NWXgwO/B/3KAPk8AdLH3VUNG0n0/YZa80U42lA3w3umw3GxQMJE2PoFyhIjJnW3jU9DlEyPGy8aIEMDkhixOWnrYuAYkWUir/i4Qi3H6k6VPxGNsTmI9dnk0ETSu2VbGBr3sPIaIGZbAsDsu1lZuya9NXdP1n4dBhJPf+k8viTzKFIbKT+Uwi5gFjZZ9uq8OZ1Y2tTM4aT8bgGtiPfhPnsEMdg==’, ‘SigningCertUrl’: ‘https://sns.ap-northeast-2.amazonaws.com/SimpleNotificationService-7ff5318490ec183fbaddaa2a969abfda.pem’, ‘UnsubscribeUrl’: ‘https://sns.ap-northeast-2.amazonaws.com/?Action=Unsubscribe&SubscriptionArn=arn:aws:sns:ap-northeast-2:427839003081:gomoku-match-topic:e0293ea8-88c0-4320-a1b8-24925381ae4d’, ‘MessageAttributes’: {}}}]}

Thanks for your support

Hey, a few questions:

  1. Do you have a queue attached to your matchmaker?

  2. If yes to #1, do you have any fleets attached to that queue?

  3. If yes to #2, do you have any available server processes in any of those fleets?

If the answer is no to any of these questions then you’ll have to address them. Typically, a match will be stuck at PotentialMatchCreated if a match has been created but there are no available server processes in any of the fleets in the queue attached to the matchmaker for the match to be hosted on.

For example, you have one fleet in your queue with only one instance running and no auto-scaling enabled that is configured to run three concurrent processes. Let’s say there are three active game sessions, but then a fourth match gets created. That fourth match will be stuck at PotentialMatchCreated until either one of those game sessions is terminated and the server process restarts, or the queue times out waiting for a server process to be available. Typically the latter scenario will result in MatchmakingTimedOut, but if the queue time out is too long, then matchmaking will time out internally still without flexmatch sending a message to the SNS topic indicating so.

hi @chrisgong
Thanks for your answer

  1. Do you have a queue attached to your matchmaker? => yes i have please see the attachment

  2. If yes to #1, do you have any fleets attached to that queue? => yes i have


  3. Yes we have 1 server process is running

This is the first time i run matchmaking for 2 difference users after create and run fleet, and the it suck PotentialMatchCreated status

So for now still could not see why it suck at PotentialMatchCreated

hi @chrisgong

It works for now, seems link lauch parameter does not work, when i want to run GameServer.exe -port 25000 then i pass +port 25000 in parameter launch? is it correct?

Thanks for your support

Depends, are you running an Unreal Engine server?

Hi @chrisgong

Yes i am running in Unity Engine and need to start server with command in local: GameServe.exe -port 25000, So how can i pass port in gamelift using launch parameter to include -port 25000

I’m not too familiar with Unity but I don’t believe it has built-in logic like Unreal Engine has to run different server processes on the same machine on different ports automatically or manually specified through a port parameter. I think with Unity you have to write some custom logic to get the command line parameter and set the port somewhere. I’m not too sure though, maybe you or someone else knows more than me on this subject.

hi @chrisgong

Thanks for support
I just mean when i pass +port=25000 in launch parameters in gamelift, then gamelift will run a process server like: C:\game\GameServer.exe -port 25000?

In that case you can just pass -port=25000 to the launch parameters.

Thanks @chrisgong

It works now