GEM ID Errors even though it was Compiled in the Asset Processor?

Recently I decided to take on LumberYard as my Permanent Game Engine Choice as its an Amazing Deal comparing to other Engines ,and since I’m only 16 I find it easier to Work With.

Recently I’ve been trying to Use it for my Projects at school to help Teach kids on the Various Habitats ,and Wildlife found in Different Forest Types ,but I have an issue as metnioned below.

I compiled it ,and waited for the Asset Processor to Process everything ,but I still get the below ,and Previously in the CMD I get this message at the buttom that says the Project cannot be found.

After that I try to launch the Editor ,but I am met with a GEM ID REfrence error of some sort ,and it Terminates itself.

Its difficult to understand what the Issue is as I have all the SDKs ,and Software installed according to the Launcher.

I also have no Solution folder ,or File of any Type to use with Visual Studio at all.

-Thanks!

Azzan!

837-49011b172c22441ed2e7b52cd7f76c96.png

Further note:

My Project is Due tommorow ,so I’m trying my Hardest to get to the bottom of this ,but I’m stumped at this time ,and would love some help.

I am having the same problem buddy. Honestly I am giving up this whole Lumberyard thing. Sorry folks, but this is not ready YET!!! I’ve spent a whole day just to pass the Visual Studio library step which is required to compile the gems

I’m having the same issue too, a solution would be nice.

I had either the same exact error or the same error with a different ID while trying to figure out which Gems were working on my system. I removed (de-enabled) Game Effect System from the Lumberyard Project Configurator after it gave me an error about its dll file missing, then got the “Dependency on Gem unmet” error on the next attempt to launch the engine. I looked down the “Dependent on” column and found that Lightning Arc has the Game Effect System as a dependency (as do a few others), so when I removed Lightning Arc, click Save, then “Back to projects” and click “Launch editor,” this particular error went away.

Hi @Azzan117, are you following the Creating a new Game Project tutorial? It looks like you had a project defined and maybe removed it in windows explorer? After you create a new project using the Project Configurator you need to run lmbr_waf configure and then compile it before running the editor. We have tutorials that give step by step instructions showing how to do this. You can download all the 1.0 tutorials from here:

https://s3.amazonaws.com/gamedev-tutorials/Tutorials/v1.0_Lumberyard_Tutorials.zip

The relevant tutorials are:

  • Creating a new Game Project
  • Compiling the Engine, Editor, and Game
    Please note that game projects have changed a little bit in Lumberyard 1.1 so if you decide to download a newer version of Lumberyard and upgrade your old project definitely check out this tutorial:

https://s3.amazonaws.com/gamedev-tutorials/Tutorials/Programming-Basics-(04)_Upgrading_a_game_project.pdf

One of the important changes is the addition of a project.json file that goes in your game projects folder (doc link: http://docs.aws.amazon.com/lumberyard/latest/userguide/lumberyard-upgrading.html#lumberyard-upgrading-new-no-source-control)

Regarding the Gem dependancy error message: this error occurs when your project is using a gem (defined in dev//gems.json) and that Gem depends on another gem that has not been enabled in your project. An example of this would be if you enabled the Amazon GameLift gem but not the Multiplayer Gem which it depends on. To fix the error, run the Project Configurator and take a look at all the Gems enabled in your project and verify all the dependant gems are enabled. Then, save the project, run lmbr_waf configure and compile the project before running the editor (these steps are detailed in the Compiling the Engine, Editor and Game tutorial I mentioned above).