High Quality Shadows

I am trying to enable High Quality Shadows on a character and I can’t seem to get the process down. I’ve read through:

High Quality Shadows

Script Canvas Shadows

Shadow Scripting Nodes

and still I’m missing something. I have the High Quality Shadow component on my character.

and a simple script canvas that should be enabling the high quality shadows based on an input.

The only thing I can think of is I don’t have a Shadow Map; but, I wouldn’t know where to place it if I did. I’ve checked through the different material types and haven’t found a Shadow Map checkbox or map input.

From what you posted it looks like your shadow should be always enabled independently from the input.Your script doesn’t toggle it, but just enable something on pressing that is just enabled from the component.

So leave away the script for a moment and try to toggle your shadow component on and off and see if you get any difference(in other cases you encountered a bug).

You don’t need any special slot as the shadow map is dynamically generated.
Also check your bounding box as the shadow is optimized around it.

Sorry for the issues. I’ve created a ticket to get someone to help you work through this.

@Gamely

Thanks for your response. I tried toggling it and didn’t see a difference. The documentation is what prompted me to create the script for the shadows as it said I needed to enable the shadows through Script Canvas.

Changing Bounding Box Scale also didn’t seem to do anything.

Hello @Taylor

I’m a technical artist on Lumberyard and I am here to help you! I haven’t used the High Quality Shadow Component yet. So, I am going to look into its setup and use and then will let you know what I discover. Stay tuned for an update!

Ciao

It works flawlessly on jack character just putting the component on it without any scripting.

Hey @BigMonet,

Through a bit more testing, it seems like the High Quality Shadows only work with the light emitted from the sun. Is that correct? My character was indoors when the shadows weren’t working and once she was outside they started working.

it is intended for use with the sun as discrete lights can be manually set up to focus their shadow resolution on characters during cinematics.

@Taylor

I didn’t see anything in our documentation about whether or not High Quality Shadows only work with the sun. I have reached out to the engineering team to find out more details!

@ECG_Taylor

I can confirm that the high quality shadows are only intended to work with the sun. This component gives an entity its own shadow map that will have a higher resolution than the global shadow map. Use it sparingly because it will cause a performance and memory impact.

You can use this component without using Script Canvas. Script Canvas would be used to dynamically enable or disable this feature. More information about this can be found on this page, Shadow Nodes.