HOrrible Performance +work around

I’m with ya… I really like the direction the engine is going on design and workflow, but feel like the effort to get and keep the average user’s interest or confidence in lumberyard is dwindling. I’m starting to think I may be wasting my time here. I know there has to be tons of content generated while designing the engine that could easily be utilized for demonstration purposes, but wall we get is vague descriptions from the manual in most cases. So…Not feeling too confident…but hopefully that will change in the future. I’m not too crazy about the other engines workflows, but damn they are active all the time.

Since you responded and I appreciate a heavy load on a relatively new engine, I"ll reinstall now. I uninstalled not sure what I was getting into with empty replies , with so many having issues with sluggish behavior.

As huntsberger, I too am sorry I feel this way as LY is so worthy, but as noted, my , yes humble system ( but its all I have, atm, working on a nice upgrade ), runs 4 terrains in world comp mode in ue4 and I never skip a beat in performance. That may change as all I have are a few meshes and terrain,but very complex terrain ( artist so…heh).

UE4 doesnt’ really have great lighting as atm there really is no, current , worked on ( as I’m told on forum) GI. Shocking isn’t it, so as Huntsberger is saying, with what LY has, GI INTACT and beautiful, -you are missing a golden opportunity.

Need more answers and better manual.

I grasp for clarity, and I know no man or company or organization can afford ALL , necessarily, but gosh Amazon I assume has a billlionare behind it so I"m a tad speechless why you guys are struggling to answer questions .

Enough of that, I don’t enjoy it.

I will reinstall,give me a day or two I"ll have answers.

Nvidia for now I have: I just installed latest driver for my GTX card ( *I DO wish,yes, it had much more onboard ;ram but I must save up for a beefier rig first) so it is:

399.07-desktop-win10-64bit-international-whql-rp

I"m pretty sure my card is only using DX11. I know it supports 12.1, 12.0 etc, but is 12 out ?

Once reinstalled I"ll get what you need.

TY for getting back to us, I was beginning to wonder but glad you are still here.

Hey @cajunctionAI, @Huntsberger, @steveH

Much apologies for the delays in response to the troubles, and the experience of sheer frustration with this topic — The team is looking into causes to fix and areas to improve on, and to help resolve your troubles, would it be possible to grab some editor logs from ya? (Please and thanks!)

I also saw that in your original post, you had mentioned the specs of your current build — i5-3570 Procesor (Ivy Bridge), Nvidia GTX 950 (2GB) with 8GB RAM.

Few questions for us to investigate further on this:

  • What Nvidia driver are you currently running?

  • What version of DirectX do you have installed on your machine?

  • When running Lumberyard, is your Graphics Card maxing out it’s memory?

Again, sorry for the troubles and we hope to get this resolved for the community ASAP :slight_smile:

// Cheers!

I have a suggestion…just hire one or two people whos sole jobs are to generate content examples, tutorials for youtube, and answer our really simple over thought out questions. I search almost every day for little tidbits of info on this engine…mostly coming up empty. I scour github looking for lua examples that would help me understand things that are not explained in the hastily written manuals. Where this engine stands right now, compared to the others, could be dominating developer channels on youtube…but it is dismal. sorry…

Thanks @cajunctionAI and @Huntsberger — I’ve made sure to get this vital feedback up to our teams for further review / improvement on your behalf. As always, we greatly appreciate the community transparency on areas of improvement :slight_smile:

Ok, reinstalled- so I loaded my current working level , all seemed fine, so going through motions I realized something I"d missed bc I’m not used to these things coming from UE4 ( maybe bc , atm, I don’t have a ‘ocean’ in UE4 so we’ll see when I do what happens to FPS though I have a few small lakes) :

The UI window dragging where terrain editor, inspector is and asset browser, that the dragging is def. alot smoother when I"m facing away from water, just as for altering texture, which is fixed as noted upon regenerating texture.

I"m not used to such atm, but I can’t complain much I know as we are in Beta, and as noted above with no ‘ocean’ in UE4 I have no perfect frame of reference.

So for now anyway that is solved which was a big one for me.

I"ll play more and see if opening inputmanager window is greatly increased long as I look away from window.

Having said all of that, its not going to be something people will enjoy if they have to be remembering to look away from fps hungry visuals just to work :slight_smile:

One last thing:

I get this error after saving , but it comes AFTER the line that saves saved successfully,:


Level successfully saved

Returned: true

(AssetCatalog) - Registering asset “levels/essence_outpost_bird_tower9_kc/tags.txt” via AssetSystem message, but type is not set.

(AssetCatalog) - Registering asset “levels/essence_outpost_bird_tower9_kc/bird_tower_incrediblelighting.xml” via AssetSystem message, but type is not set.

(AssetCatalog) - Registering asset “levels/essence_outpost_bird_tower9_kc/essence.xml” via AssetSystem message, but type is not set.

(AssetCatalog) - Registering asset “levels/essence_outpost_bird_tower9_kc/filelist.xml” via AssetSystem message, but type is not set.

(AssetCatalog) - Registering asset “levels/essence_outpost_bird_tower9_kc/essence_outpost_bird_tower9_kc.xml” via AssetSystem message, but type is not set.

(AssetCatalog) - Registering asset “levels/essence_outpost_bird_tower9_kc/tags.json” via AssetSystem message, but type is not set.

(AssetCatalog) - Registering asset “levels/essence_outpost_bird_tower9_kc/terraintexture.pak” via AssetSystem message, but type is not set.

(AssetCatalog) - AssetRemoved: path=levels/essence_outpost_bird_tower9_kc/essence_outpost_bird_tower9_kc.dds id={567E8609-CABD-5E7B-A2DB-EC51B2B23628}:0

general.save_level

Saving to Levels/Essence_outpost_bird_tower9_kc/Essence_outpost_bird_tower9_kc.ly…

(Editor) - Saving level backup to ‘C:/Amazon/Lumberyard/1.15.0.0/dev/StarterGame/Levels/Essence_outpost_bird_tower9_kc/_savebackup/2018-08-31 [10.52.17]/’…

[Warning] Attempting to save backup to C:/Amazon/Lumberyard/1.15.0.0/dev/StarterGame/Levels/Essence_outpost_bird_tower9_kc/_savebackup/2018-08-31 [10.52.17]/ before saving, but could not write all files.

I have no idea what to make of it as I was not getting that error before- and /or should I make a new thread out of that error , wasn’t sure so I just put it here for now.

thx

Hey @cajunctionAI,

Thanks for sharing your observations and logs – super happy to see the big obstacles dissolving on this issue! :smiley:

I’ve added this note for our devs to dig into further, and get improvements made for upcoming releases. Also, let me poke around some more and see if there are other things that can be done to help propel performance in the mean time :slight_smile:

Thanks again for being patient and awesome!

Alrighty, @cajunctionAI so for this new warning try re-exporting the terrain textures, and Export to Engine. It might resolve the warning that is being generated on level save -

HI ty so much AL for reply,

I don’t know what you mean by re-export textures,export to what , I’m not following you here…I"m using built in textures,HM or did you mean re-generate textures, and then export to engine ?

The latter :slight_smile:

Re-gen textures and then export to engine —

HI sorry got busy, so I"m getting these errors now doing regen tex’s, no idea what they mean: