How do i import beach city assets and legacy game sample?

How do i import beach city assets and legacy game sample?

Check this out: https://docs.aws.amazon.com/lumberyard/latest/userguide/sample-level-beach-city-night-assets.html

Yep… correct :slight_smile:

I was wondering the same thing. Thanks for your response, but I tried that, and the project just doesn’t show on the project configurator… Any ideas for why this can happen?

EDIT: Forget it, I extracted all the contents on a single folder inside the Lumberyard root, but you have to extract everything inside the root.

Could you upload a screenshot of the project.JSON file cause i think this is where its goinng wrong. i extracted beach city and legacy into the lumeryard folder then tried adding the code and nothing still comes up

Could you upload a screenshot of the project.JSON file cause i think this is where its goinng wrong. i extracted beach city and legacy into the lumeryard folder then tried adding the code and nothing still comes up

Try this…

You will require the three packages from the Amazon Download page…

  1. Woodlands Asset Package

  2. Beach City Asset package

  3. Legacy Game Sample (CryEngine GameSDK)

https://aws.amazon.com/lumberyard/downloads/

What I did was back up my folders first. Please do this

Open the woodlands Asset package folder - Located in c:\Lumberyard/dev/gems/AssetCollection_Woodland. (If you installed it in default location).

Then from the Beach City folder, (This is in your lumberyard/dev folder) I grabbed all the materials, objects, textures and terrain folders and merged them into my woodland assets folder, I then done the same with the GameSDK package folder, I grabbed all the material, objects, textures and terrain folders and merged them with the woodland asset folder.

Once this is done you then have all the assets in one GEM. (Woodland Assets)

The next step is to open the project configurer, set the sample project as the default then go to the ‘enable packages’ option (top right) and make sure the woodland asset is ticked.

Now when you run the editor it will have to load up all of these assets into your game, give it time.

It took 20 minutes on my PC and this isn’t an old one!

Once this has completed you should have access to all of the assets from all packages.

I’m completely new to programming. I know how to copy paste, but I’m having trouble with imputing the code to the projects.json file. A screenshot of what is supposed to look like in the file would be helpful. The VS editor keeps saying things like “unexpected separator” and I don’t know enough yet to figure it out. I tried placing a comma after the second to last bracket, but it didn’t like it.

sounds good but can you run the Beach City level with this setup? I can’t… when I switch to game mode nothing happens.

I have the same problem, there is no player controller in my Beach City level too!,

If you had all the assets loading in then I think it would just be a case of loading up the level in the sample project to enable the use of the robot as a controller. Copying the ‘BeachCity_NightTime’ level folder into your start projects level folder may work.

Hey, in case anyone out there needs this. Because none of the above seems very clear or helpful to me. After extracting Legacy and Beach, go into those new folders, grab the dev folder, merge it with the dev folder in your main Lumberyard directory. NOT under gems. NOT under Woodland Assets. Merge the sample dev folders with the main dev folder under Lumberyard. If you did it right, you’ll see those two options immediately appear in Configurator the next time you run it. Good luck.