How to install ffmpeg SDK?

Hi, how do I install the ffmpeg SDK for Lumberyard? The Setup Assistant doesn’t really give clear instructions. I’ve downloaded static, shared, and dev versions of ffmpeg 3.2.2 and placed them in the 3rdParty folder.

Okay, I figured out how to install the SDK for FFmpeg 3.2:

1. Download the ‘dev’ and ‘shared’ versions from the FFmpeg site and extract them.

2. Open your 3rdParty folder and create a new folder called FFmpeg.

3. Create a folder inside the created FFmpeg folder called 3.2.

4. Go into the folder for the downloaded FFmpeg ‘dev’ version and copy the ‘include’ and ‘lib’ folders into the newly created 3rdParty/FFmpeg/3.2 folder.

5. Go into the folder for the downloaded FFmpeg ‘shared’ version and copy the ‘bin’ folder into the 3rdParty/FFmpeg/3.2 folder.

6. Refresh your Lumberyard Setup Assistant and check it.

hi , go to it’s website and download latest version (zip file). AFTER downloading ,put it anywhere extract it , and in last set to the path through the lumberyard setup assistant, set path till bin folder of ffmpeg

I did that and it has a check mark next to it in “Install Software”.

Under “Install optional SDKs” however, it still says the SDK is invalid. How do I fix that?

When I build with Video Playback Gem enabled, I’m still getting “Cannot open include file: ‘libavcodec/avcodec.h’: No such file or directory.”

I thought you could use either libav or ffmpeg? Why is it looking for libavcodec?

Hi @arineto, did you try the steps outlines in the post above by @Malpracticing_Artist?

same here:

Cannot open include file: 'libavcodec/avcodec.h': No such file or directory

@Binky_LY yes, the only way it works is installing the libav and the ffmpeg

in another computer I did not have to install libav… maybe it is something with the first note I was using… just following the steps from @Malpracticing_Artist

Hi i managed to install the FFmpeg stuff however i cant install libav it gives me linker error LNK 2019 it seems to work with just FFmpeg i just cant select a video source the only option i get is an empty window the name Pick

video-playback.png

what to download specifically? I see a lot of links on the official site FFMPEG…

Last time I tried was in 1.26 but there was a link to another website showing you 4 builds and LY setup showed you what to install from there, but that site went down during 4.26 and now I have no clue none of those are named the same, maybe a dev could help on this one to get everyone else on the same page on what to install. Sorry I am not a lot of help, I want to know the answer as well.

I hope someone can help us …

1 Like

Are you guys sure you want it:


It does look like 3.2 is no longer available to download, but have you tried same steps @Malpracticing_Artist described above with current version? I haven’t tried rebuilding, but LY Setup Assistant did accepted it when I placed 4.2 bin and include where it wants it, this one has both:
https://www.gyan.dev/ffmpeg/builds/packages/ffmpeg-4.3.1-2021-01-01-full_build-shared.7z

If that doesn’t work, you could try grabbing 3.2 source from github, building it youself and structuring include files like they are in shared 4.2.

2 Likes

I managed!
What I’ve done:

  1. Downloaded the archive and placed the folders

  1. compiled the project via command line


3) Completed these



4) done!

now next problem … I cannot add video snippet