How to make a Release build of my game project in AL 1.5?

hello friends , in this time i am trying to making of release build of my game project in pc plateform.

i am a level and environment designer not programmer.so

i followed Lumber docs(10 steps release build process ) but some step is more confuseble.

in step 5 , step 8 AND step 9 , I can not understand these steps, step 8 &9 says copy something but what and where is location of pasting of these file.

i am trying 2 times but i can not do it.

please help.

Step 5 should be alright since you build pak files at a later step.

Pak files are packages of compiled assets and shaders.
In step 7 you run BuildShaderPak_DX11.bat, if that was successful you end up with the packed shaders in the dev/Build/pc/PROJECTNAME/D3D11 folder.

These both pak files (the shadercache.pak and the shadercachestartup.pak) needs to be moved to your ‘**dev/**PROJECTNAME_pc_paks/PROJECTNAME’ folder.

In step 9, you need to move your Binary folders as well. They have been created inside ‘dev’ in Step 2 & 3. The binary folders need to be placed in '**dev/**PROJECTNAME_pc_paks’.

So you end up with a hierachy like this (don’t mind some scripts that you do not have, those are own creations):

feedback images

feedback image2 dev root folder

after launcher running

now i am doing try a fresh project.

in step6 , for generating shader file, shader compiler server is needed. where can i found this server?

i am find shaderlist.txt

On step 6 of http://docs.aws.amazon.com/lumberyard/latest/userguide/game-build-release.html it says “doing one of the following”. You can have a server that builds your shaders and assets but thats for if you are working in a production team where everyone should have the same assets and shaders.

It says samplesproject_pc_pak in the top. You must have build the wrong project and your launcher cant find the correct project directory (because it is actually not there).

Run the SetupAssistant.bat which is located outside of the dev folder.
Click through to the last page (or click on Summary on the left), there you click on Configure Project. There you can select your actual project you want to build and set it as the default project.

Then you need to run lumbr_waf.bat configure over the command promopt inside your dev folder, and then start the whole release build steps from that link again:

http://docs.aws.amazon.com/lumberyard/latest/userguide/game-build-release.html

hello,

you are saying that i am build wrong project, while, in docs there are clearly mention that " step 4 Run BuildSamplesProject_Paks_PC.bat (located in the \dev directory). Alter the path as needed to reference your game if you do not want to include SamplesProject. The .bat file generates a \samplesproject_pc_paksdirectory that includes all files required to run your game, excluding shaders and executables."

whenever, i run BuildSamplesProject_Paks_PC.bat then it make automatically samplesproject_pc_paks folder in dev root dir . its means that , for tt_pro_pc_paks i will need a .bat file like this “BuildSamplesProject_Paks_PC.bat” . and after this run , a folder will generatre with my project name like"tt_pro_pc_paks"

but there is not generate bat file for my project in Dev root dir.so i can not create tt_pro_pc_paks folder

Ah I see, you have to write that batch on your own.Something like “BuildMyProject_Paks_PC.bat”:


@echo off
setlocal enabledelayedexpansion set ORIGINALDIRECTORY=%cd%
set MYBATCHFILEDIRECTORY=%~dp0
cd "%MYBATCHFILEDIRECTORY%"
REM Attempt to determine the best BinFolder for rc.exe and AssetProcessorBatch.exe
call "%MYBATCHFILEDIRECTORY%\DetermineRCandAP.bat" REM If a bin folder was registered, validate the presence of the binfolder/rc/rc.exe
IF ERRORLEVEL 1 (
ECHO unable to determine the locations of AssetProcessor and rc.exe. Make sure that they are available or rebuild from source
EXIT /b 1
)
ECHO Detected binary folder at %MYBATCHFILEDIRECTORY%%BINFOLDER%
echo ----- Processing Assets Using Asset Processor Batch ----
.\%BINFOLDER%\AssetProcessorBatch.exe /gamefolder=MyGameProject /platforms=pc
IF ERRORLEVEL 1 GOTO AssetProcessingFailed
echo ----- Creating Packages ----
rem lowercase is intentional, since cache folders are lowercase (for ps4)
.\%BINFOLDER%\rc\rc.exe /job=%BINFOLDER%\rc\RCJob_Generic_MakePaks.xml /p=pc /game=MyGameProject /threads=cores+2
IF ERRORLEVEL 1 GOTO RCFailed
echo ----- Done -----
cd "%ORIGINALDIRECTORY%"
exit /b 0
:RCFailed
echo ---- RC PAK failed ----
cd "%ORIGINALDIRECTORY%"
exit /b 1
:AssetProcessingFailed
echo ---- ASSET PROCESSING FAILED ----
cd "%ORIGINALDIRECTORY%"
exit /b 1

FML, I typed everyhing down and then closed the window before sending…

Okay again:

You copy the 'BuildSamplesProject_Paks_PC.bat**’** that is in the dev folder and rename it to whatever you want, with a .bat ending.

Naming it to **’**BuildTTpro_Paks_PC.bat’ is probably suitable.

Then you right click it, and open it with the Editor/Notepad.

All you have to do is change SamplesProject behind ‘/gamefolder=’ to your project folders name, and for the ‘/game=’ name you change it to your project folders name in lower cases.

Save that script then and run it in the command prompt.

oops, i am a simple level + environment designer ,so can you tell me , where is location of this file? or where is it done?

i am used this button3673-idmfg.jpg

i am unable to add a map

Okay, to eliminate, that it is usually not like that, can you run **’**lmbr_waf build_win_x64_profile -p all’ in the command prompt to make a ‘normal’ build and then launch your PROJECTNAMElauncher.exe that should be in the Bin64 folder after it has finished?

Is that black as well?
Then its a problem of the game, if not, then we made a mistake on making that release build.

But are you able to open the console by pressing the Circumflex (Button left of the ‘1’)?
If so then you basically did make a release build.
And calling a map with the command ‘map MAPNAME’ does not work?

If you get a console, try typing ‘map’ and then press the Tab key for available options.
Or no, I think it was ‘?map’ to see all options you have as command argument.

Perfect would be, if you can open the console and typing ‘?map’ there gives you a list of all the levels you made in the project. This means you are almost there!

according to you i found this result

i am also tried to sampleproject. launcher of releaseproject is not working, it is like TT_pro launcher in release_build. while whenever i run sampleproject_launcher from lumber1.5/dev/ BIn64 folder it is working of console command and sample map is running.

see image below

Okay, this is getting hard to help because it could be many things.
One thing is that it does not compile, and the output does not point me into a helpful direction.

Then the Launcher seem to work, but how if you couldnt build?
Why is the screen black, is there a camera?

I would make sure that the normal profile build works, that it compiles fine.
The SetupAssistant would be a good place to start, to make sure that everything is installed and set up correctly.

Oh and also, you have to make sure to Export the Level to the engine before you are able to load it.
So in the Editor, hit Ctrl+E or go to ‘File > Export to Engine’ in the menu bar.

The release build should be the last thing to pack it if your errors are all fixed.
You should not fix errors when you build release.

i am also tried 1.7 lumberyad but trere is same problem with sample and custom release.

can lumber team provide a video tutorial on this topic?