Import Mixamo model and animation in EMotion FX

Hello,

I’m trying to import a Mixamo .fbx model into Lumberyard. The .fbx model is in my project and I can see it in my Asset Browser. However, I can not drag and drop the fbx in the viewer.

  1. I tried to open the Animation Editor and to open an actor, but the fbx is not visible in the “Pick EMotionFX Actor” browser.

  2. I tried to create an Empty Entity, add an Actor Component and Anim Graph Component, but when I try to browse for the Actor asset, the model is still not visible.

https://docs.aws.amazon.com/lumberyard/latest/userguide/component-actor.html

I found a tutorial on how to import model and animation from Mixamo to Lumberyard, but that was by using the old system (Geppetto).

https://www.youtube.com/watch?v=3YYrpHVQflY

I’m not sure what exactly I’m doing wrong.

Anyone is able to help me?

Thanks

Hello,

Thanks for answer! I managed to fix my issue with the actor not being detected. However, when I apply animations on the actor, the mesh of the actor becomes wierd.

I found a post of someone who had the same issue:

https://forums.awsgametech.com/t/emotionfx-animgraph-problem/4745/1

His solution seems to be: import the animation with the skin, then remove the mesh and actor from the fbx setting.

This fix doesn’t seem to work for me. I still have the same result.

Without skin:

6497-fbx-settings.png

With skin:

6499-animation-with-skin.png

Interesting – sorry for the troubles @Malof. Let me get some answers for you :slight_smile:

Hi @Malof - I am not sure what exactly the Mixamo FBX file contains, but if it does contain the character’s skeleton in a bind pose and a deformable skinned mesh, you can extract an Actor from that.

Open your Asset Browser from the main Tools menu, and navigate to your FBX file in the Asset Browser. Highlight your FBX file, then Right+Click and select “Edit Settings” from the menu.

This will open the FBX Settings window, which will allow you to edit what you are extracting from the FBX file. If you do not have the CryAnimation Legacy gem enabled, you will only see three tabs in this window, “Meshes”, “Motions” and “Actors”. If the Asset Processor has already found animation in your Mixamo FBX file, it has probably already made a Motion out of that, and there will be Motion information in the Motion tab, as well as a Motion file noted underneath the FBX file in the Asset Browser.

6546-fbx-derived-files.jpg

In order to create the Actor manually, if the Asset Processor has not recognized that your file contains an Actor, you just need to add one using the Actors tab on the FBX Settings window. So go to the Actors tab, and click on the “Add another actor” button to add one.

6547-fbx-settings-add-actor.jpg

Once you click on this, it should add the Actor to this tab. Check all the Actor settings are what you expect, and that it has the meshes you want by hitting the button at the far right of the “Select meshes” field.

So if there was a bind pose inside your Mixamo file, it should have found the root joint correctly, although you can also adjust which bone it uses as the root. Now when you hit the “Update” button on the lower right of the FBX Settings window, the Asset Processor will pop open a window, and process your FBX file to derive the Actor from it. Once it does that, you should then see the “Actor” file type appear below your FBX file in the Asset Browser as in the second image above.

One other thing you can do, if you don’t want the animation in your Actor file (i.e. you have an Actor file which is only the character in a bind pose with no animation) is to remove the Motions from being considered. This is optional, but if you want to clearly separate your Actor from your Motions, it may be helpful.

Just go to the Motions tab, and hit the “Add another motion” button to refresh the interface and add the little “X” buttons on the upper right of each motion. Then you can just click the little “X” button on each motion and remove all motions, so that ONLY the Actor is being derived from this file. This would only be the case if you didn’t want the motion - so if you want it, just leave it!

OPTIONALLY REMOVE ANY MOTIONS YOU DON’T WANT:

6550-remove-motions.jpg

Now that you have an Actor from your FBX, you should be able to open it in the EMotion FX Animation Editor, as well as add it to an Actor component on your game level.

Hope this helps!

Hi @Malof - I also tried some test Mixamo FBX files (“ty.FBX” and “Walking.FBX”) and was able to successfully derive an Actor from the “ty.FBX” file, but not the “Walking.FBX” file. So there is a bind pose and meshes in the “ty” file, which allowed me to derive the actor as I outlined above.

6561-ty-actor.jpg

I was then able to open the Actor in the EMotion FX Animation Editor, and add the Walking motion to a Motion Set, and play it on the ty character successfully. So this means that you can derive the Actor from Mixamo FBX files, and then add Motions, which should allow you to progress with building a character’s animation graph in EMotion FX.

ty Actor in t-pose in the Animation Editor:

ty Actor playing the Walking animation in the Animation Editor:

Hello @Castor,

I installed Fuse and made characters with it, and it seems to work. The issues I was having seem to be related to models on Mixamo.

Thanks

Hello @Castor,

I tried with the Ty character, with a walking animation and it seems to work.

So I guess the issue comes from the other model.

I’ll try to find the problem.

I am using the: Akai E Espiritu model.

Hello @Castor,

I tried with multiple models on Mixamo and I always get the same issue.

The only model that I tried so far that doesn’t have this issue is Ty character.

Hi @Malof and @Castor ,

I just so happened to be working on emtoionFX with mixamo models as well and came across your posts. Very helpful with the Ty model point!

Have you guys had troubles with animations being imported being cut down in frames to 93? Seems like all animations (idle, walk, and run) that I import are being sliced down. Also, I’m new to this, but I noticed that the simpleJack animation loops while continuously walking forward in the preview, but animations I import from mixamo are resetting to their origin.

@Malof @naotoy The Akai E Espiritu model has a problem with the way it was animated. The root joint moves from 0,0,0 and causes problems with looping. I used the same model in a UE4 project a loooong time ago and had to check a box in UE4 that basically overrides the root movement and keeps it at 0,0,0. I haven’t looked at LY’s animation system yet, but hopefully it has a similar function.

https://forums.awsgametech.com/t/adding-mixamo-assests/1183/5?u=lumbermixalot