Install software: How can I get "Python Scripting Language" set up successfully?

I managed to get everything else (Android NDK, SDK, Java JDK, DX, Wwise, amd FFmpeg) all set up, but Python just won’t get found.

The python version (3.5.1) linked (“Get it”) in the Lumberyard installer is 32 bit.

  • I ran this 3.5.1 one and it didn’t work. I uninstalled and ran it again with admin privs and it still couldn’t be found. Found out it’s 32 bit so thought maybe I needed 64.

  • Went to a different page on the linked python site and found a list of most all the versions for various OSes. https://www.python.org/downloads/windows/

Tried the Windows x86-64 web-based installer therein, chose custom and clicked every box so it installed everything. Then…

  • I had a system environment variable for “Path”, changed its directory to that of the actual 64bit one just installed above(…C:/Program Files/Python35), refreshed lumberyard launcher and nothing. Added an extra env. var. PATH to system variables, gave it “C:/Program Files/Python35/”, refreshed LL(Lumberyard Launcher), still not detected.

Anyone know of a literally step-by-step guide to set it up on Windows 7 64bit?

Thanks a lot in advance! (I’ve spent a good 2 hours on this already. Not fun.)

Hey, @Jason

I wrote a detailed response, had to sign back in because apparently I got auto-logged out and now it’s gone…

  1. I typed “python” into cmd line and it returned something to the effect of: python 3.5.1 AMD 64.

So I guess that means it’s successfully installed.

  1. I’m not sure exactly what you mean by executing a script (please forgive me if I misinterpreted, I haven’t used python too much). This is what I did:
  • created a test.py and saved it on the desktop

  • added one line to it: print(“Hello!”)

  • then in cmd navigated, cd’d, to Hans/desktop/ and typed “python test.py” and it returned: Hello!

Does that mean scripts are running on my machine?

Thanks!

Hey RudolfVonKrugstein,

Note: I tried to “Reply” to your comment, but it just wouldn’t submit (tried twice). Sorry, but this is NOT an answer.

(I’m the OP; this is my “other” account)

Checking
for a reply to my latest comment, I ran into a different thread (linked
below) with a resolution that’s kind of similar to the prob you and I are experiencing. Its contents fortify my suspicion that system env. vars are the primary culprit.

https://forums.awsgametech.com/t/install-software-woes-ndk-python/856/1

When
I get back to work tomorrow (14 hours from now) I’ll give the env var finagling described in that aforementioned thread a try - that is unless
one of the LY devs could give some clear cut instructions on how to set
up them vars. (I’d prefer the latter, mainly because the poster in the
other thread was using Windows 8 64-bit and Python 2.7.10 - wink2 nudge2)

Hi there @Hans@games, sorry you’re having this problem. let’s see if we can get this working.

  1. Have you verified that Python was successfully installed on your machine?
  2. Can you verify that python scripts are actually running on your machine by executing a script?
    Once we know that Python was successfully installed, we’ll work on making sure the Lumberyard Launcher recognizes it to properly complete the installation.

Thanks

I have exactly the same situation. Python 3.5.1 is succesfully installed and I can exeute scripts.

Any help?

I had similar difficulties in getting the LL to detect my installation of Python, but Android development is not critical to me at this point, so I just gave up and disabled the option on the first page. 8-( Hopefully it will be fixed in a future update so that I can test it later on.

I’ve noticed the same problem with the forum not properly submitting replies on these forums and it’s quite annoying. But I just copy the full text of my reply (Ctrl+A, Ctrl+C) before clicking Submit and when it doesn’t work I paste it in again and click Submit again and it seems to work. I’m wondering if the problem is that there’s some kind of time-out that’s occurring between clicking the Reply and Submit buttons that is removed when pasting a reply and clicking Submit.

(Reply is still broken / won’t “Submit”. This is not an answer.)

Update:

On the work Windows 7 64bit PC, I:

-Tried uninstalling all previous python version 3.5.1 (namely 32bit launcher and 64bit). No pythons installed.

  • Installing the default Python 2.7.10 (first one that appears on the page “Get it” links
    to - let it install at default C:\Python27)

-Removing the old env. vars entries for C:\Program Files\Python35 under PATH (system and user env. vars)

-Added C:\Python27\ to PATH for both system and user env. vars

-Clicked on Browse to the right of Python Scripting Language in Lumberyard Launcher and set it to C:\Python27 where python.exe is located

-Refreshed the launcher (curved arrow in the top-right)

-The launcher still can’t find it

Hey ScottCE,

Thanks for all the pointers. What you’ve decided to do seems the best way to handle the situation at present.

Glad to help, but I sure hope they get that fixed soon. I’m sure there are plenty of people wanting to create Android games with Lumberyard.

I was having that problem too. Then I uninstalled Python 3.5.1 and installed Python 2.7.11 instead. Updated PATH, launcher still couldn’t find it when I hit refresh. But then I restarted Lumberyard Launcher, then it seems to work. But I am using Windows 10.

@Jason

bump^

It’s been almost 2 weeks since I’ve heard anything from you. There are others looking for help with this (at least 2, RudolfVonKrugstein and ScottCE).

I recently attended a Lumberyard meeting at the company I work for in Japan. I mentioned your reply was late in coming and they assumed it might have something to do with GDC.

That’s good and all, but to me it indicates you guys are short-staffed.

I have the same problem on Win 7 x64 and with different versions of Python.

Hello everyone,

I apologize for the lack of updates on this thread. We are very busy trying to improve lumberyard and I know for myself I can forget to check the forums and provide support to all of you. :slight_smile:

I took a look at the code that is trying to detect python and here is some information that I believe will be helpful:

  1. We only support python 2.* versions. I’ll double check our documentation to make sure this is specified clearly. I believe we include version 2 of Python in the 3rdparty directory so you should be able to browse there for the python installation.
  2. To validate the installation we run the following command: python -c “import sys; print sys.exeutable”. If this fails to run that would cause us to not detect python. The resulting output from this command is then used as a file name and we try to check the existence of the file. If that fails then we won’t detect the python installation either.
    We know this is a pain point and have this on our list of things to fix. We are also looking at what is required to support python 3.*.

ChrisC,

Thank you very much for the detailed and helpful response.

I apologize for my tone in my last post despite the fact I knew you guys were busy…

Thanks again!