Is lmbr thirdpartysdks setup broken?

I’m trying to set up an automated build of a Lumberyard project, and I would like to be able to setup the build without any user interaction. Cloning the git repo, running git_bootstrap.exe to install some dependencies, and using SetupAssistantBatch.exe to specify my desired capabilities have all worked just fine. However, I can’t get “lmbr thirdpartysdks setup” to work.

I noted the Known Issues with this command in the release notes, and made the recommended change to my SetupAssistantUserPreferences.ini file. However, the command still fails, though this time with a new error:

D:\Amazon\Lumberyard\Foo\dev\Tools\LmbrSetup\Win>lmbr thirdpartysdks setup
lyzard: Acquring missing SDKs: boost, sqlite, jansson, nvapi, p4api, pdcurses, tiff, fbxsdk, squish, libtomcrypt, libtommath, mikkelsen, freetype2, alembic, hdf5, ilmbase, szip, zlib, wwiseLtx, qt, powerVRTexTool, etc2comp, AWSNativeSDK, GameLiftServerSDK, GoogleMock, lz4, Lua, expat, md5, LZSS, Lzma, AMD_AGS, OSVRSDK, Dyad, rapidjson, rapidxml, jinja2, markupsafe, jsmn, OpenSSL, civetweb, DirectXShaderCompiler
"contentunavailable_https://df0vy3vd107il.cloudfront.net/1.12.0.0/boost/1.61.0-az.2/manifest.1.0.0.common.json: Creating retry system (Max retries: 0)(Time to reset: 0)(Delay set: " QVector() )
"https://df0vy3vd107il.cloudfront.net/1.12.0.0/boost/1.61.0-az.2/manifest.1.0.0.common.json: Download request failed (Content Does Not Exist: The file you are requesting does not exist on the server. Check the log for details.)"
"https://df0vy3vd107il.cloudfront.net/1.12.0.0/boost/1.61.0-az.2/manifest.1.0.0.common.json: Exceeded download retry count, not retrying download"
lyzard: Error: --- Failed to download boost. ---
QWaitCondition: Destroyed while threads are still waiting

Am I missing some other configuration step? Or does this tool just not work correctly yet?

Nobody else tried to use this feature at all?