Is there a sub forum for PS4 developer or I just shoot out the platform specific question here?

Title says it pretty all. As you can see from here AWS problem I can not just use the editor. Its driving me crazy. I have compiled the engine, editor etc, and in the compilation step I am getting warning(sce__ blah blah not found etc). But the compilation finishes though and I can not login.

Someone please help.

I had some issues when I was first compiling as well. One thing that held me up at first is that when building the project for the first time it says to use the command “lmbr_waf.exe build_win_x64_profile -p all --progress”. When you copy and paste that into the command prompt, however, it tends to exclude a hyphen before the word progress (-progress). Make sure you have both hyphens before the word progress (–progress) if you want to use that function.

Alternatively you can omit the “–progress” function and try the command “lmbr_waf.exe build_win_x64_profile -p all” (without the quotes of course). Just make sure you have navigated to where you have the “Lumberyard\dev” folder installed in command prompt before trying to run that command. As a side note on this, one unfortunate limitation of Lumberyard is that it will NOT run from a folder path that contains any white spaces. I tried putting it in my program files initially but this will not work. Just put it in the root of your C drive (or the root of any drive for that matter, as long as it is not in a folder with white spaces).

Not having the optional plugins and programs installed should not cause your project build to fail. You simply would not be able to use their functionality in your project until you do install them, so I would ignore that as being a cause of your issue (as long as you are only referring to the optional components).

Also, I will try to summarize the steps to getting the editor running below in case I am misunderstanding your issue. In the future, when you are requesting help with errors, try to include the ver batim error message as opposed to writing “something something blah blah”. Not knowing what is not found prevents others from being able to address your exact issue.

One thing I can add to the discussion, I did not install any max or maya sdk prior to the compilation. Is it something I must do?

So I looked through your log and compared it to my own. I do not see any differences between them other than what is listed for our different hardware. Looking at your screenshot it seems as though everything was built and compiled properly and the only remaining issue is your ability to login with your amazon account.

After doing some searching the only other post similar to your issue was your post about this specific issue. That being said, logic compels me to focus on two possibilities.

  1. Somehow your download and installation of Lumberyard is corrupted only in regards to its authentication system. Your best solution to this would be to re-download Lumberyard. I highly doubt this is the case though, which leads me to the next logical possibility.

  2. You have some sort of firewall or IP filter, either on your computer or the network you are running your computer on, that is preventing the connection to the Amazon services. My guess is that if Lumberyard fails to connect to the authentication servers when it initially prompts you to login that it disables the ability to interact with the authentication windows, thus causing the issue you are having of not being able to type into it. Since I do not work for Amazon, I can not confirm this with absolute certainty, but it makes sense. After reading your other post regarding this issue, it sounds as if you are running Lumberyard on a work computer and are unsure of how to tell if something is blocking your connection.

As a simple solution to possibility number two, I used a program to try and determine the IP and port number that Lumberyard uses for authentication. I was able to determine that the Amazon authentication uses https on port 443 for outbound TCP connectivity to login. I also came up with several IP addresses that Lumberyard communicates with on this port during login.

54.239.25.13

54.239.24.185

54.239.24.186

54.239.23.94

54.239.22.25

continued below

NOTE: These instructions assume that you have everything that is not listed as optional in the launcher installed.

  1. Put the extracted lumberyard folder in the root (this is important) of a drive.

  2. Open an administrator command prompt.

  3. Navigate (aka change directory) to the “Lumberyard\dev” folder where the WAF executable is located. As an example, if you have the Lumberyard folder in the root of your C drive, you would type “cd c:\lumberyard\dev” into the command prompt (as always without the quotes). Leave the command prompt open for now.

  4. Using the Lumberyard launcher, go to the summary section that is listed on the left side of the launcher. From that page, in the top right-hand corner, click on “Configure Project”. Click on the blue “New Project” button and give your project a name, then click ok. It will give you a message telling you to run a command before you can run the project. We will be getting to that next. For now, just click ok, then click on your project to highlight it. Then in the top right click “Set as Deafault”.

  5. Switch back to the command prompt and run the command “lmbr_waf.exe configure”. This will build the Visual Studio solution needed to build your projects and run the editor. In addition, this will check to ensure you have everything necessary installed. If you get an error her, chances are there is something not listed as option in the launcher that still needs to be installed. Fix anything you need to here as necessary and run this again to make sure you do not have any errors before moving on.

  6. If the Visual Studio solution was built without errors, then while still in the command prompt (and still in the “c:\lumberyard\dev” directory) run the command “lmbr_waf.exe build_win_x64_profile -p all --progress” (again, make note of the two hyphens before the word progress and make sure they are both there). This will check for any un-built projects, including your newly created project, and build them.

Continued below

  1. From the Lumberyard Launcher, simply click on “Launch Editor” in the top right of the summary page. You should now be prompted to login to amazon (if you have not been prompted before) and load into the editor asking you to create a new level for your project.

Most of this information was taken from: https://s3.amazonaws.com/gamedev-tutorials/Tutorials/Programming-Basics-(02)_Compiling_the_Engine_Editor_and_Game_v1.pdf

If you need additional help or get stuck on any of this, be sure to include any error messages exactly as they appear as well as which step you are stuck on.

Hope this helps!

awserror.jpg

I did all stated here, freshly, as far as I can remember. And the same result, I can not give username and password in the input fields. No matter what I type, nothing appears on those two input field.

Editor log: 1233-editor.txt (16.5 KB)editor.txt

A bug or what? Please fix this issue.

Regards,

Kaiyum

Even though I have no troubles connecting to the above listed addresses when using the editor, I was unable to successfully ping any of those listed IP addresses which means that Amazon has pinging its network disabled, which is unfortunate for our troubleshooting case.

In this case, the only way to check if this is indeed the cause of your issue, you would need to be able to have access to your network’s router settings as well as have administrator privileges to check your Windows firewall (or any other firewall software you may have installed) on your computer.

The latter is the easiest to check, assuming you have admin rights, since you can simply turn off Windows firewall (or any other firewall software) then try to open the editor again and see if you are able to login at that point, which tells you that you need to make some exceptions to allow traffic. If you are on a work PC, even if you have admin rights, your company’s network guys probably won’t be happy about you doing that, just as a fair warning.

As far as checking your network settings, if you are trying to connect on a computer that is on a company network, it would need to be configured to allow traffic in the above listed IP range as well. Basically open up the IP range of 54.239.0.0 to 54.239.127.254 for port 443 on a TCP connection.

That being said, after some more digging I came across this page:

http://docs.aws.amazon.com/workspaces/latest/adminguide/client_ports.html

which confirms what I found in regards to Amazon’s authentication. Further more, if you follow the AWS IP Ranges link on that page, it will bring you to a link to:

https://ip-ranges.amazonaws.com/ip-ranges.json

which gives us the entire range of IP addresses that amazon uses, including the range I listed above.

As far as Amazon needing to fix this, I do not believe anything is broken with the editor, nor do I believe what you are experiencing to be a bug. I do, however, think it would be nice to have an offline mode to the editor.