Linux fleets no longer activating

Hi there,

Have been discussing this in PM, but figure it might also be helpful to post here in case anyone has an answer.

Our recent Linux builds have been timing out while activating, which I thought might have been due to something we changed (either in the build itself or fleet settings etc.), but I’ve just gone back and created a new fleet from an old known-working build, and it also gets stuck in activating.

Has anything changed on the GameLift side that could cause this? Are there any logs stored anywhere from the activation step?

I’ve been able to SSH into a fleet once in Error, but it doesn’t seem like the game is getting to the point where it’s started logging, which makes me think it’s failing to even launch the binary properly. I originally thought it was a permission issue or something, and tried a bunch of testing with different install scripts that set ownership and chmod etc. but nothing has worked. I’m able to run the server fine when I manually start it over SSH, but it just seems that GameLift is having trouble for some reason.

We’ve just been using Windows fleets for the time being, but would love to get back onto Linux. Any help would be greatly appreciated!

I was actually able to get an old build into the ACTIVE state by reducing the processes per server. Will now try to increase until it gets stuck activating.

Is there a way to tell what error is causing it to fail at higher process numbers? Just because we’re able to get 30 processes per server on Windows, so I’m surprised that we can get at least that many on Linux.

On a side note - when I try to get the SSH credentials of fleets that have become ERROR, I just get a GameLift error:
An error occurred (InternalServiceException) when calling the GetInstanceAccess operation (reached max retries: 4): Failed to create host credentials

Update 2:
After some more testing, it seems that 10 processes gets to Active, but 15 processes ends up in Error. I tried to SSH into the latest errored fleet to see some system logs, but there are apparently no instances, despite the fact that the “CPU Utilization” metric is spiking up and down. Is that expected?