Loads of Errors

I have been getting loads of errors and have been reinstalling over and over to guarantee that it isn’t user error during setup.

Failed to load dynamic library at path "C:/Amazon/Lumberyard/1.12.0.0/dev/Bin64vc140/
Gem.CryEntityRemoval.Editor.f3ae24a1635e4f849535f37ef9f4b4da.v0.1.0.dll

That gem was enabled by default. I disabled and enabled other gems as needed, tried to rebuild, and was faced with this;

Have you tried ending the Asset Processor and all Lumberyard tasks in the Task manager? Also, When you go to build the project. First do you use “lmbr_waf configure” and then “lmbr_waf build_win_x64_vs2015_profile -p all” and do you also run the command prompt as Administrator?

@THE_F0X Did you rebuild the project after enabling The CryEntityRemoval Gem?

I am getting the same error when I attempt to run the Editor with a new project.

I’m not familiar with the ‘Advanced Settings’ available with new projects. I did select that and noticed it automatically loaded a number of required components. One of these is the CryEntityRemoval component. The window doesn’t behave well, but it works. I assume the components listed have been added anyway.

It might be helpful if I could find the log of the failed build attempt. It looks like a lot of the errors are related to being ‘unable to find QT’. Then a bunch of errors. I don’t have a full list, but here is a sample of one of the errors. They all have a similar format, just unable to open a different include file.

Example:

    <++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++>

Compilation failed - File: ‘DockMainWindow.cpp.6.obj’, Module: ‘AzQtComponents’, Configuration: ‘win_x64_vs2015|profile’, error code 2
Input Files: ‘f:\Programs\Lumberyard\1.12.0.0\dev\Code\Framework\AzQtComponents\AzQtComponents\Components\DockMainWindow.cpp’
Output Files: ‘f:\Programs\Lumberyard\1.12.0.0\dev\BinTemp\win_x64_vs2015_profile\Code\Framework\AzQtComponents\AzQtComponents\Components\DockMainWindow.cpp.6.obj’
Command: ‘C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\BIN\amd64\CL.exe /nologo /WX /MP /Gy /GF /Gm- /fp:fast /Zc:wchar_t /Zc:forScope /Gd /wd4530 /wd4351 /Ox /Ob2 /Ot /Oi /Oy- /FS /Wv:18 /bigobj /showIncludes /MD /W4 /wd4127 /Z7 /GR- /If:\Programs\Lumberyard\1.12.0.0\dev\BinTemp\win_x64_vs2015_profile\Code\Framework\AzQtComponents\AzQtComponents /If:\Programs\Lumberyard\1.12.0.0\dev\Code\Framework\AzQtComponents\AzQtComponents /If:\Programs\Lumberyard\1.12.0.0\dev\Code\CryEngine\CryCommon /If:\Programs\Lumberyard\1.12.0.0\dev\BinTemp\win_x64_vs2015_profile\Code\Framework\AzQtComponents /If:\Programs\Lumberyard\1.12.0.0\dev\Code\Framework\AzQtComponents /If:\Programs\Lumberyard\1.12.0.0\dev\BinTemp\win_x64_vs2015_profile\Code\Framework\AzToolsFramework /If:\Programs\Lumberyard\1.12.0.0\dev\Code\Framework\AzToolsFramework /If:\Programs\Lumberyard\1.12.0.0\dev\BinTemp\win_x64_vs2015_profile\Code\Framework\AzFramework /If:\Programs\Lumberyard\1.12.0.0\dev\Code\Framework\AzFramework /If:\Programs\Lumberyard\1.12.0.0\dev\BinTemp\win_x64_vs2015_profile\Code\Framework\GridMate /If:\Programs\Lumberyard\1.12.0.0\dev\Code\Framework\GridMate /If:\Programs\Lumberyard\1.12.0.0\dev\BinTemp\win_x64_vs2015_profile\Code\Framework\AzCore /If:\Programs\Lumberyard\1.12.0.0\dev\Code\Framework\AzCore /IC:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\INCLUDE /IC:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\ATLMFC\INCLUDE /IC:\Program Files (x86)\Windows Kits\10\include\10.0.10240.0\ucrt /IC:\Program Files (x86)\Windows Kits\NETFXSDK\4.6.1\include\um /IC:\Program Files (x86)\Windows Kits\8.1\include\shared /IC:\Program Files (x86)\Windows Kits\8.1\include\um /IC:\Program Files (x86)\Windows Kits\8.1\include\winrt /If:\Programs\Lumberyard\1.12.0.0\dev\Code\SDKs\rapidjson\include /If:\Programs\Lumberyard\1.12.0.0\dev\Code\SDKs\rapidxml /If:\Programs\Lumberyard\1.12.0.0\dev\Code\SDKs\Lua /If:\Programs\Lumberyard\1.12.0.0\dev\Code\SDKs\zlib-common\include /If:\Programs\Lumberyard\1.12.0.0\dev\Code\Tools\SDKs /D_WIN32 /D_WIN64 /DCODE_BASE_FOLDER=“f:/Programs/Lumberyard/1.12.0.0/dev/Code/” /D_PROFILE /DPROFILE /DNDEBUG /DQT_QML_DEBUG /DAZ_QT_COMPONENTS_EXPORT_SYMBOLS /D_MT /D_DLL /DBINFOLDER_NAME=“Bin64vc140” /DPLATFORM_SUPPORTS_AWS_NATIVE_SDK /DUSE_WINDOWS_DLL_SEMANTICS /DLY_BUILD=526767 /DRESOURCE_COMPILER /DFORCE_STANDARD_ASSERT /DNOT_USE_CRY_MEMORY_MANAGER /D_CRT_SECURE_NO_DEPRECATE=1 /D_CRT_NONSTDC_NO_DEPRECATE=1 /DWIN32 /DWIN64 /DKDAB_MAC_PORT /DAZ_ENABLE_TRACING /DAZ_ENABLE_DEBUG_TOOLS /DEXE_VERSION_INFO_0=1 /DEXE_VERSION_INFO_1=12 /DEXE_VERSION_INFO_2=0 /DEXE_VERSION_INFO_3=0 f:\Programs\Lumberyard\1.12.0.0\dev\Code\Framework\AzQtComponents\AzQtComponents\Components\DockMainWindow.cpp /c /Fo f:\Programs\Lumberyard\1.12.0.0\dev\BinTemp\win_x64_vs2015_profile\Code\Framework\AzQtComponents\AzQtComponents\Components\DockMainWindow.cpp.6.obj’
Output:
DockMainWindow.cpp
f:\Programs\Lumberyard\1.12.0.0\dev\Code\Framework\AzQtComponents\AzQtComponents/Components/DockMainWindow.h(17): fatal error C1083: Cannot open include file: ‘QMainWindow’: No such file or directory
<++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++>

That was DockMainWindow.cpp unable to open include file ‘QMainWindow’. Here are a few more . . .

ButtonDivider.cpp unable to open include file QWidget

DockTabWidget.cpp unable to open include file QTabWidget

DockBarButton.cpp unable to open include file QWidget

FancyDockingDropZoneWidget.cpp unable to open include file qglobal.h

FancyDockingGhostWidget.cpp unable to open include file QWidget

HelpButton.cpp unable to open include file QPushButton

ButtonStripe.cpp unable to open include file QWidget

DockTabBar.cpp unable to open include file QWidget

EditorProxyStyle.cpp unable to open include file QtGlobal

FilteredSearchWidget.cpp unable to open include file QWidget

Previously I believe I saw a QT.json file in the WAF 3rdParty directory. There isn’t one there now, so perhaps I am mistaken. However, I never did see a QT directory in the Lumberyard>3rdParty directory, assuming that is one possible location. No QT folder/shortcut in the Lumberyard>dev>code>SDK directory either.

Is there anything further I can do that might help track down this problem? Let me know if there is anything I can test or any logs – and where they are located – that may be useful.

Thanks and Happy Holidays! =)

Hey @Douglas – thanks for providing details on this topic. Nothing yet, but much thanks for checking in on this and your patience! Most of the team is out celebrating this wonderful season with family and friends at this time; our apologies for the delays on the forum responses D:

Will update this thread as soon as we can :slight_smile:

Happy Holidays to you as well!

Hey @Konshu – is this still an issue with 1.12.0.1? I’ve pinged a couple of peers for iteration on this topic. Apologies for the delays :frowning:

@Amonster_LMBR any update to this? Any new basic project I build with no additional gems runs into the same issues.

@THE_F0X, @Douglas, @Konshu

I just saw this thread and wanted to reach out to you all. I am a Technical Artist on the Support Team here at Lumberyard. Are you all experiencing this error when you create a new project that did not exist before? Or experiencing it after switching default projects? If so, I have some suggestions that will probably help you all out.

After creating a new project or switching default projects and enabling or disabling the Gems that you want to use, check the following files and make certain that the name of the newly created project is included in them:

  • …\dev*bootstrap.cfg*
    • Open this file and confirm that sys_game_folder = YourProjectName
    • ProjectConfigurator.exe should set this for you, but sometimes it does not.
  • …\dev_WAF_*user_settings.options*
    • Open this file and confirm that enabled_game_projects = YourProjectName
    • ProjectConfigurator.exe should set this for you, but sometimes it does not.
      This appears to be a bug and we are trying to find the exact reproductions steps that causes it to happen. It is tricky because it does not happen to everyone. But, it happened to me just last week! Let me know if this information helped you all out. We are always watching the forums and trying to give everyone a good experience. Good luck!

It is still an issue. I have been stuck on this for two days not and still can’t figure it out.

Thanks for the suggestions!

I updated to Lumberyard 1.12.0.1

I checked bootstrap.cfg and user_settings.options, they looked good.

Unfortunately, I’m not certain if 1.12.0.1 made things better or worse. When I run the editor with my project set as default I quickly get the following error:

That error seems familiar, so I’ll check on this further when I get a chance. Now that I have Lumberyard updated, it should be easier to test the configuration. Let me know if anyone else has any suggestions, I will gladly give them a try as soon as I can find the time! :stuck_out_tongue:

Sorry it took so long to test this much. My Dad ended up in the hospital after Christmas. I’ve been traveling back and forth to the hospital since then. That probably contributed to me getting the flu at the start of the new year. Due to problems over the holidays at work, I’ve ended up helping cover extra hours and for the last week or two I’ve been working 60+ hours a week. Fortunately, I took a day off yesterday to be on hand when my Dad was released from the hospital – he is doing well – and I had a little spare time to update Lumberyard and give this another try. =)

@Douglas

I hope your dad is doing well and heals quickly! As for you, get some extra rest so you stay strong too. I’ll see what else I can do here on my end to resolve this issue. A few other things that come to my mind immediately are:

  • …\dev\YourProjectName*gems.json*
    • This .json file lists all the gems that you have enabled for your project
    • Confirm that the gems you have enabled are in this .json file
    • If you have the CryEntityRemoval gem enabled, it should be listed in this file
    • Also right-click on this file and make certain that it is not set to Read-only
  • After creating a new project, make certain to run the configure step:
    • Run: lmbr_waf.bat configure
    • When that is done, if using VS2015: lmbr_waf.bat build_win_x64_vs2015_profile -p all
    • When that is done, if using VS2013: lmbr_waf.bat build_win_x64_vs2013_profile -p all

Thank you for the reply! I will try this out when I get the chance and let you know if it helps me.

To answer your first question it happens when I try to create a new project that did not exist before.

I have the same error, but with the EMotionFX gem.

Appeared after initial compilation, then suddenly and magically dissapeared (can’t reproduce the steps to get it working) but now - again - after switching default projects it reapeared.

I’m on that issues for 3 days now.

  • I compiled game/all/tools for several times (with lmbr_waf and vs2015

  • reconfigured with the lmbr_waf

  • checked dependencies, and the dependencies of the dependencies

  • wscripts of project and gem

  • json files of project and gem

  • access permission of the editor (everything as administrator(except for the lmbr_waf console tbh)

  • I switched projects again

  • Tried recompile everything from scratch (deleted bintemp and binaries)

  • Oh well - nearly forgot the most important step: I switched off and on again. hehe - At least I’m still able to joke after that frustration. :wink:

Can’t get it to work again (except for when disabling the gem…)

Update #1: And ofcourse I tried your suggested steps, files are looking good.

Is there any advanced logging at editor startup? Can’t find anything related to that.

Update #2: Started things up in the power shell and noticed an error trace

Checked the file, well, sadly no time to debug currently, but its obviously pointing to file descriptor, probably thats the issue?

Another thought of me was that probably the dll is already in an “in use” state so the process isnt allowed to load it? probably by another instance/thread of the the whole app? So kind of “order-issue”?.. just guessing though…

Update #3: I dont really know much about the engine, just starting using it, but probably things I figured out are helping.

I downloaded 1.12.0.0 from the git repo, and clean installed it (deleting everything related to 1.12.0.1), I didnt setup to compile engine/tools etc… just game code compilation, after initial setup and lmbr_waf configure I compiled with game param, and tried to start it up afterwards, i got the cryentity dll missing error. I switched the setup to compile engine and tools too, config -> compile -> 34 minutes later I successed and started the game again - it started with some warning/error (right bottom corner toast) from the assetprocessor but it actually started up. (same gems loading as my previous testproject where I got the EMotionFX dll missing error.

Everything compiled with profiling setting!

Hopefully this information can help!

I created an “Empty” project and did not add any Gems, so these are all added
to the project by default and listed in the gems.json file:

LyShine, LegacyGameInterface, CryLegacy, Maestro, SceneProcessing, TestProject/Gem, CryEntityRemoval, LmbrCentral

The gems.json file is ‘not’ set to Read Only and the CryEntityRemoval gem is listed. I have run the configure and build a few times. It looks like I used the same commands you provided, but I ran it again anyway.
I used copy and paste to run your commands.

Running lmbr_waf.bat configure appears to have been successful with the same, or similar, warnings as before.
Running lmbr_waf.bat build_win_x64_vs2015_profile -p all resulted in numerous errors.
I suppose that isn’t too surprising given the warnings though. I think these errors are the same ones I posted previously.
I checked the filepath:

F:\Programs\Lumberyard\1.12.0.1\dev\Code\Framework\AzQtComponents\AzQtComponents\Components

The files appear to be in the correct location.

Can you share a screenshot of the errors you are getting now?

By chance are you trying to build an external game project?

Last question, can you describe the process step by step that you are using to create a new project?

Im getting same error on all new projects. The samples all open fine though! Perhaps some configuration error when writing new projects? Further information - I installed beta on two machines at same time (no previous installs) - win10 machine operates fine - win7 machine has this error. @Amonster_LMBR

I decided to try and reinstall Lumberyard 1.12.0.1

The error appears to be the same as before; a missing dll file. There are ‘similar’ files listed, but the one shown in the error does not appear to be there.

I thought it might also be useful to get video of the installation. I edited the video into a series of smaller clips in a YouTube playlist that can be viewed here:

https://www.youtube.com/playlist?list=PLvtq82QGgg4irGMb17TwKSiKierqM8-zo

Interesting – I’m very sorry for this experience @psk. I’m checking in with some peers on this. Stay tuned :slight_smile: