Lua debugger does not break on breakpoints

Hi,

I had an issue earlier which I was able to solve where the Lua editor would not connect to the LY editor.

Now I am able to attach to the LY editor from the Lua editor, however, none of the breakpoints I set in the script are being hit. I know that the code is being reached because I have a log message where I put one of the break points and another breakpoint on the line above the log message and although the message appears in the console, the Lua editor does not hit the breakpoint. I’m not sure where to go from here. Thanks!

Hi @imp10,

Can you try this?

  1. Make sure the Lua editor is connected to the editor by checking the status in the top bar in the Lua editor. The far right icon should be green, if not, click it, ATL+TAB to the editor and ALT+TAB back. This should also make all of the Lua functions appear in the Classes Reference panel.
    2899-luaconnected.jpg

  2. Set your breakpoint in the Lua script by clicking in the left column on the line where you want the breakpoint (it should appear as a red dot)

  3. In the editor, enter game mode (CTRL+G)

  4. In the Lua editor select Debug > Run On Target

  5. Your breakpoint should get hit and you can step over, continue etc.
    Here’s a link to our documentation on the Lua editor and it has more information:

http://docs.aws.amazon.com/lumberyard/latest/developerguide/lua-editor-debugger.html

Let me know if that works for you or if you have questions. We’re still improving the workflow here, but hopefully this will get you started.

Hi, thanks for the reply.

The procedure you detailed is just what I have been trying. Unfortunately, when I get to step 5, none of my breakpoints are hit.

One thing I am curious about it step 4 (your image seems to be broken but thats not an issue since its an easy step). I do not see this step in the developer guide walkthrough although I have tried it both ways with the same result. My question about this and the previous step is whether it is necessary to enter game and then hit Run on Target for debugging to work. If that is the case, I would think it would be impossible (or difficult) to debug the OnActivate function for an entity on screen initially.

Either way, this does not seem to be working for me.

One more piece of info I can think of is that when I add or remove breakpoints in the Lua editor and then toggle back to the LY editor, I get console messages telling me about the breakpoint (added breakpoint at line… etc) yet they are never hit.

Thanks again

Hi,

I have problem to connect LuaIDE to Editor target, because I do not have Editor target in the list of LuaIDE. Soo I have no chance to debugger work for me. GridHUB I have activated but there is only Editor connected and GridHUB_copyapp_. Do you have any idea how to solve this problem ?

Hmmm, can you check your firewall settings and see if Gridhub and/or the Lua IDE are blocked?

I am happy to check but I am not exactly sure how to do that. I looked at Windows Firewall Advanced Settings but I cant find Gridhub or the Lua editor in either inbound or outbound lists. Admittedly, I am not very savvy in this area. If you could let me know what I should be looking for I would appreciate it! Thanks

Hi @petrocket,

This buttons close to Target:

3081-debugger-icons.jpg

are inactive so it’s doesn’t work for me (I was try with Alt + Tab).

Maybe do you have any other idea ?

Hi @jasiuj,

Next time you have the editor and the Lua editor open, try pressing the image next to the “Target” button, ALT+Tab to the editor and then ALT+Tab to the Lua editor and see if more items appear in your Targets list.

As an update, I turned on firewall logging and tried to debug again. I did not see anything blocked in the log.

Are there somebody else for whom debugger it is not working too ? Maybe do you have some thinking about it ?

Hi @imp10, I’m looking into this with the team and hope to have an answer for you shortly.

Hi @jasiuj, I’m trying to get you an answer as well.

Thank you :slight_smile: let me know if you will need something from me like dxdiag log …

The team is looking into this issue. I’ll let you know if we need more information as well as try to provide a solution as soon as I have one for you. Thanks for the patience.

Hi @Binky, thanky you very much :slight_smile: It is quite importane feature for my :slight_smile: Please let me know if you will need something from me to resolve this case :slight_smile:

Hi,

Just out of curiosity, were you able to reproduce this? Do you need anything else from me? Thanks!

Hi @imp10,

  1. Have you tried using some of the test scripts that come with the engine to verify that they are working/not working.
  2. What version of Lumberyard are you currently using?
    Thanks in advance for the info.

Hi, I couldnt reply to your last comment (we might have reached the nested limit) but in answer to your questions

  1. Yes, I have been doing my testing using the controllable chicken sample code

  2. I am using Lumberyard version 1.6.0.0

Are you able to reproduce this on your end? Thanks

Mine is not working reliably.some time it is still connected(green icon) but doesn’t step into break points or even doesn’t load the latest updated script , so editor still run a previous iteration making editor restart the last hope to see it reloaded(neither menu script reload all fix this).

Another issue with debuggin is that every time I have to put my pc name in the connection facilitator app(that in the windows tray) or it doesn’t see the server.It is expected to remember it as pc name is not something easy/usefull to remember.

Hopefully a lot of these issues will be fixed with the next update (Beta 1.7). That should be coming very soon.