LuaRemoteDebugger does not breaks on breakpoints

Hi,

External LuaRemoteDebugger does not breaks on breakpoints. It is connects to Editor as I see in Editor Console but it does not stop at breakpoints for scripts in project folder either in project cache folder. I type lua_debugger 1 in console off course.

Do you have any idea ?

Hi @jasiuj, I’m trying to track down an answer for you.

Thank you @Binky :slight_smile: I am awaiting for your diagnose.

Hi @jasiuj I have a couple of questions for you to help diagnose this issue:

  1. Have you tried using some of the test scripts that come with the engine to verify that they are working/not working.
  2. What version of Lumberyard are you currently using?
    Thanks in advance for the info.

Hi @Binky,

Thank you that you take investigate on it. The problem is that I cannot connect from LuaIDE to Editor because this buttons are disabled and Target and Context lists are empty:

3081-debugger-icons.jpg

ad.1:

I make just a few tests with sample application UIEditor_Lua_Sample. The problem is the same. Debugger do not work.

ad. 2:

I use LY 1.6.0 but I have checked it in LY 1.5.0 where the problem is the same.

I think that the problem may be connected with Windows 10 ? Do you test it at this platform ? Do you have the same problem ?

ps.

I attache dxdiag for more info: 3094-dxdiag-2.zip (16.5 KB)dxdiag-2.zip

Hi, I am having a similar problem and just thought I would try to keep all of these topics tied together so that the same things are not asked and answered over and over.

Here is a similar topic by the OP: https://forums.awsgametech.com/t/debugger-not-working-cannot-connect-to-gridmate-service/1539/1

And another: https://forums.awsgametech.com/t/lua-debugger-not-working-cannot-connect-to-editor/1586/1

And here is one by me: https://forums.awsgametech.com/t/lua-debugger-does-not-break-on-breakpoints/1542/1

If this has been reproduced by anyone else please let me know. Also, if you have had luck breaking on breakpoints in the Lua editor please give me a test scenario that works for you so I can try it on my end and we can potentially determine what the differences are between our environments. Thanks!

Make sure that a program called ‘GridHub’ is running (the ‘.exe’ can be found in the binaries folder). This program connects the various Lumberyard programs to one another and needs to be running in order for the LuaEditor and the Lumberyard Editor to connect to each other.

I had a similar problem and I noticed that my version control (Perforce) was causing a binary to be read-only causing it to not run properly. If you do use Perforce then make sure you checkout ‘GridHub.exe’ and ‘GridHub_copyapp_.exe’ (or just make sure the two files are NOT read-only).

As I see my files are readable and problem still exists ;p

Hi @Binky,

I am just wondering if this may help you:

09:32:56|GridMate : Trace::Warning

d:\ly\workspace\PKG_v1_6\dev\Code\Framework\GridMate\GridMate\Replica\Replica.cpp(657): ‘bool __cdecl GridMateForTools::Replica::Unmarshal(struct GridMateForTools::UnmarshalContext &)’

09:32:56|GridMate : Received unknown replica chunk type 0x6f69ff36 at index 1, discarding 26 bytes.

Do you verified it on Windows 10 ? I have this problem on it. ?

Thanks

Hi, I dont mean to hijack this but wanted to say thanks for the update on this issue and to clarify. Is the known bug only related to the remote debugger as per this question or is it also for the debugger in the lua editor as related to the other questions I linked elsewhere in this thread (and by the looks of it, also in the screenshot on this thread)? Thanks!

I’ve reported back to the team and am trying to get you a solution still. I hope to have some useful information soon.

EDIT: This is a known bug, a fix ticket has been filed and this issue should be fixes in the next release of Lumberyard. Sorry for the hassle and thanks for the patience.

Thank you @Binky, so I am awaiting for next release :slight_smile: Do you know when it will be released ?

We haven’t released a date as of yet but it shouldn’t be too far off in the future.

Thank you @Binky :slight_smile:

Hi @Binky_LY, Unfortunatelly debugger still not works in LY 1.7 :frowning:

I posted on the other thread but wanted to post here too. I think there is a bigger issue happening and I am going to have one of our techs hop in here.

@Binky_LY I have one question. Why GridHub is trying to connect in this ip adress 169.254.80.79.

Shouldn’t he try connect to localhost?

Here is my log:


09:29:13|GridMate : GridMate Allocator has already started! Ignoring current allocator descriptor!
09:29:13|GridMate : 09:29:13|GridMate : ================================================
09:29:13|GridMate : = GridMate initialized: Version 00.01.0263 =
09:29:13|GridMate : = Build on: Fri 10/11/2013 11:42:40.81 =
09:29:13|GridMate : ================================================
09:29:13|GridMate : Replica type GridMateLANSessionReplica(0x5fc67dc5) already registered. New registration ignored.
09:29:13|GridMate : Replica type GridMateLANMember(0x5cc7d4c8) already registered. New registration ignored.
09:29:13|GridMate : Replica type GridMateLANMemberState(0x512ecdb2) already registered. New registration ignored.
09:29:13|GridMate : 09:29:13|GridMate : ================================================
09:29:13|GridMate : = GridMate destroyed: Version 00.01.0263 =
09:29:13|GridMate : = Build on: Fri 10/11/2013 11:42:40.81 =
09:29:13|GridMate : ================================================
09:29:13|GridHub : Current IP 169.254.80.79 is invalid! We will try to start the session again in 10 seconds...

Hey @Binky_LY, this is important because in LY 1.7 are big warning to not use Flow Graph because it will be deleted and ask to use Lua instead. But without debugging it’s quite difficult and no one can downgrade their Windows 10 to earlier version to use it. So it’s quite big problem for user or studios with new version of Windows (where currently you can buy only Windows 10). Do you reproduce this problem ? How can I help you to resolve it ?

Hi @Binky_LY, I will do that (in LY 1.6 I made a clean reinstall of LY without VS and it didn’t helps so |I am hope that here will work). I will let you know if will help. Do are some registry in windows register information which I should delete too ?

I will download clean VM https://developer.microsoft.com/en-us/windows/downloads/virtual-machines to try on clean installation.