lumberyard 1.18.0.0 lmbr_pak_shaders.bat not creating build dir with local shaders paks

I am familiar with lumberyard I have been playing/building projects with it for since 2014, so I done this step many times before.

Testing Lumberyard 1.18.0.0

Creating Release Builds for PC

https://docs.aws.amazon.com/lumberyard/latest/userguide/game-build-release.html

I am trying to build a simple release build of the simple sample project, or StarterGame.

I have complete all the build steps and can test the release build.

(Creating Release Builds for PC -

Completed: generated shaders by navigating the levels in Lumberyard Editor.

The shader pak step build fails (3.Build and pack the shaders)

ISSUE:

(when I run the lmbr_pak_shaders.bat I get a output line

expected usage: “lmbr_pak_shaders.bat D3D11|GLES3|METAL pc|es3|ios|osx_gl [source shader list file]”)

and no \Build\pc\<em><code>SamplesProject.with my shaders pak’s.

I tested the parm path to the shadercache.txt in (

lmbr_pak_shaders.bat StarterGame D3D11 pc E:\Amazon\Lumberyard\1.18.0.0\dev\Cache\StarterGame\pc\user\cache\shaderlist.txt)

)

, all I get it is looking for the remote shadercache serverat localhost or loopback 127.0.0.1

Also I followed the edit the lmbr_pak_shaders.bat (here) - but the instructions do not look vaild anymore and does not work for me, just outputs the same line.

(Here)

                                   If you are not in the Samples Project, customize the

lmbr_pak_shaders.bat batch file before you
run it. To do this, edit the highlighted parameter in the following
example.


<code>...
set SOURCESHADERLIST=%1 (does not change anything!!)
set GAMENAME=<em><code>SamplesProject (does not change anything!!)

FYI:

set DESTSHADERFOLDER=Cache%GAMENAME%\PC\user\Cache\Shaders (no such line in file!!!)

                                The batch file output specifies the directory where the packed shaders

are located, such as
``

E:\Amazon\Lumberyard\1.17.0.0\dev\Build\pc\SamplesProject``

I have tried the other troubleshooting related steps here did not change not sure what else could be wrong, this and I have replicated this on 2 computers and 2 lumberyard reinstalls both sample projects!!! all the same.

Shader Cache and Generation -

https://docs.aws.amazon.com/lumberyard/latest/userguide/mat-shaders-custom-dev-cache-intro.html

And there are no errors in user build log’s everything loads that I can see.

** And my release build end results are a black screen or black screen with
audio effects and I can move the jack character based on sound effects I
here just no graphics.**

lmbr_pak_shaders use to work on older lumberyards builds before 1.18.0.0

So to continue troubleshooting, I am going back to lumberyard 1.17.0.0 and see if lmbr_pak_shaders.bat works and that I can complete a release build on that older build.

OK I created a release build for sampleproject in lumberyard 1.17.0,0 and there is a script called BuildShaderPak_DX11.bat and it created (shadercache.pak, shadercachestartup.pak) as expected.

when running the sampleproject_pc_paks, the lumberyard logo start screen is displayed and then the level. So that is working.

But my lumberyard 1.18.0.0 does not have this BuildShaderPak_DX11.bat it has lmbr_pak_shaders.bat and it does not work for me. this BuildShaderPak_DX11.bat does not work in lumberyard 1.18.0.0 as expected. And the (shadercache.pak, shadercachestartup.pak from lumberyard 1.17.0.0 sample project does not work in lumberyard 1.18.0.0 sample project. :frowning:

I guess I try the copy the local shadercache manual to shadercache.pak and shadercachestartup.pak method as a last test, but that is not a very good solution if it works.

(OK that worked, copy over the

E:\Amazon\Lumberyard\1.18.0.0\dev\Cache\SamplesProject\pc\user\cache\shaders\cache\d3d11 or your project Shader Cache

to shadercache.pak, shadercachestartup.pak and move to the release folder\project.)

my opinion lmbr_pak_shaders.bat does not work like previous lumberyard builds/

BuildShaderPak_DX11.bat Manual blanket copy of shaders method worked for me.

OK I am done with this.

Hope this helps anyone with the same issues I had in Lumberyard\1.18.0.0 and building shaders for a release build.