Lumberyard 1.27 disappearing water

I tried creating a new level and the terrain as per the youtube video but there was no water visible. This has also happened to many others. Any idea what might be the issue… My graphics card is a gtx1080ti. Works well because i am using unreal and unity.

Add the “ocean” component.

Thank you
I tried these steps

Here he gets it directly… Without using any ocean

In the latest edition of lumberyard the ocean is extracted out and put into the water gem. If you disable the water gem then the ocean will automatically be added to your level. (I believe).

Thank you i will try that… I need to disable the gem… Hmm… I still need to wrap my head around these gems…

Instead of removing the Water Gem, I would definitely suggest keeping the Water Gem and just adding the Infinite Ocean component to an entity in your level, as this is the preferred method for adding the ocean. wcb is 100% correct in that disabling the Water Gem can also cause the ocean to get added automatically, but this is just preservation of legacy behavior where the ocean always got added to a level no matter what. The intended workflow in Lumberyard is to add the Water Gem and deliberately add or remove the Ocean component to any level that should have an ocean.

2 Likes

Thank you very much for your replies… Much appreciated… I tried disabling water gem and restart but the issue remains… I have added the infinite ocean to the entity and it works perfect…thank you… Well i actually also wanted to teach newbies about the engine hence i was wondering how john diaz got it automatically in his video… :+1:

So make it simple for whoever comes by

All i did is

  1. right click in the editor and select create entity
  2. On the right side entity inspector click on add component and type in the search bar infinite Ocean… And boom… There you go
1 Like