Lumberyard Beta 1.10 feedback

[Dedicated 1.10 Feedback Thread]

Now that you’ve had some time to experiment with Lumberyard Beta 1.10, we’d love to hear your feedback and thoughts on your experiences. What are some of the things you liked most? Was there anything that didn’t quite work as you thought it should?

Your feedback helps us make a better product for everyone.

Hi Amonster_LMBR and Lumberyard Team.

1.10 version is very nice, but most different from others game engines in Lumberyard have AWS and GameLift. For me that is the most think why i trying working in him.

I would be glad to see :slight_smile:

  1. fix GameLiftLocal or help to find answer, I very long time waited GameLift Local for more faster testing my game but can`t start working with him. (Possible this is not bug, just my not good knowledges)

  2. If it possible create more flexible update GameLift SDK. On this moment how i understand each version of Lumberyard have definite version GameLift SDK. Example in Lumberyard 1.10.0.0 have GameLift 3.1.5 but on this moment have newest 3.1.6 And will be nice if Lumberyard Team create way to update for GameLift. I hope this is a possible.

  3. Add ClothComponent like a StaticMeshComponent to LmbrCentral it will be nice :wink:

From version 1.2 to 1.10 i see many good features, fixes and addons. Thanks to Amazon and Amazon Lumberyard Team for so big work.

Cheers,
Anatoliy

Thank ya kindly for this perspective @Anatoliy :slight_smile: I’ve added this to our feedback list and am getting some answers for you on the AWSClient - Request failed issue!

Thanks for creating this feedback forum. 1.10 is the first version of LY I’ve tried, and I had a few issues with getting started, so I’ll detail those here first.

  1. I ran into a confusing error with installing 3rd party dependencies. I’ve added info to this existing thread.

  2. The setup assistant also gives an error along the lines of ‘SDK invalid - hash doesn’t match’, when the SDK simply hasn’t been installed yet. That can be a bit confusing too.

  3. SpeedTree installation in the setup assistant didn’t seem to work. On specifying the installation path, there was no error but the status just didn’t change.

  4. I also faced this login error. It kept telling me the password was incorrect, despite the fact that I could login to the Amazon website without issue. I had to create a second account in order to get into the LY editor.

  5. Probably not a LY-specific issue, but I am constantly being logged out of the LY/Amazon site. It rarely seems to last more than an hour or so, even when I check ‘Keep me logged in’. Quite a pain.

Thanks @kamrann! I’ve logged these perspectives to our feedback list for further action. I am terribly sorry for the negative experiences — let me try to get expedited responses for each item listed :slight_smile: Will update this thread as soon as I can. Thanks again and Cheers!

Hi ! Thanks for your great engine.

But I ran into some issue, the water volume shader doesn’t have environment texture slot if I create a new one, so I can’t turn on realtime reflection I guess.

In the example level which already have a water volume and I found there have a environment slot in the watervolume material.And the wired thing is that if I remove the environment texture, the environment slot will disappear…I don’t know it’s a bug or if I miss something?

Thank you for being a part of the community! :smiley:

I’m very sorry for the troubles – let me check in with our techs for a response. Would it be possible to create a dedicated thread on this for tracking? This would be helpful for support, however, it is primarily for the community members who I’d imagine are seeking similar answers to questions or topics like so :slight_smile:

Definitely tag me if you do make a thread so that I can make sure we have unity between the two posts on our end!

Thanks again, and let me see about getting you answers ASAP!

Good morning!

I am a technical artist with the Lumberyard team and was reading through your inquiry! We actually have a fix for this targeted for our next release, so I would keep an eye on our notes as the new versions release!

In the mean time, there are a couple of example water volume materials you can manually copy, which will give you the parameters you need. The easiest to access is in the StarterGame Project.

In your Material Editor (StarterGame Project):

Game - Materials - water - watervolumes

Or in Explorer:

dev - StarterGame Project Dir - Materials - water - watervolumes

Hope this helps and thanks for bringing this to our attention!

-MajorBliss