Lumberyard Beta 1.12.0.0 Setup Assistant (using/installing extremely outdated SDK's)

The Amazon Lumberyard Installer (Lumberyard Setup Assistant) for v1.12.0.0 seems to be installing/requiring extremely very very outdated SDKs, and seems to use extremely old versions of required SDK’s. Can you please update the Amazon Lumberyard Setup Assistant (Installer) to update the required SDKs to the following very latest versions of the latest SDKs:

Alembic (currently requires v1.5.5 SDK), should be updated to require latest v1.7.5 SDK

AudioKinetic Wwise LTX (Lumberyard Installer currently requires v2016.1.1.5823), AudioKinetic Wwise LTX should be updated to require the latest v2017.1.4.6407 [18+ new releases/versions/builds/updates have been released since the very old 2+ year old version build/release (v2016.1.1.5823),that the current Lumberyard v1.12.0.0 is currently using] Lumberyard Setup Assistant should be updated to use/download/install the very latest AudioKinetic Wwise LTX ( v2017.1.4.6407 )

Amazon Web Services SDK for C++ (currently requires v1.1.13-pkg.1), should be updated to require the latest v1.3.29 release.

Autodesk FBX SDK (currently requires v2016.1.2), should be updated to require latest v2018.1.1

AMD GPU Services (currently requires v2.2), should be updated to the latest v5.1.1

Boost (currently requires v1.61.0), should be updated to require the latest v1.66.0

CivetWeb (currently requires v2016.09.22), should be updated to require the latest v1.10

I can go on and on and on, about the long list of old/outdated SDK’s and the Amazon Lumberyard Setup Assistant should be updated (every release) to support/download/install the very latest 3rd party SDK’s (latest versions/release) but it seems that the Amazon Lumberyard Setup Assistant is not using the very latest SDK’s, and is often using extremely old (and outdated) SDK releases (with bugs, security issues, etc.) and the Amazon Setup Assistant is not using/downloading/installing the very latest SDK’s as part of the Amazon Lumberyard Setup/Installer.

Can you please update the Amazon Setup Assistant (to use the very latest releases of 3rd party SDK’s) and then release a new Lumberyard v1.12.0.1 release (with the updated installer) so we can begin testing the latest build of Lumberyard with the very latest SDK releases?

Thanks,

Mark

Can you also update the Lumberyard Setup Assistant to support the very latest SDK for “FFmpeg” to v3.4.1 (latest stable release) instead of v3.2

Latest FFmpeg releases/builds can be found here:

https://ffmpeg.zeranoe.com/builds/

Also can you please add/update the Lumberyard Setup Assistant (v1.12.x) to add/update the following “Optional SDKs” (in the “Install Optional SDKs” in the Lumberyard Setup Assistant) and please add/update the following to “Install Optional SDKs” in the Lumberyard Setup Assistant add the following:

  • Add “Autodesk 3ds Max 2017 SDK

  • Add “Autodesk 3ds Max 2018 SDK

  • Add “Autodesk Maya 2018 SDK

Can you update the Lumberyard Setup Assistant following SDK’s in the “Optional SDK’s” to the latest SDK versions as well:

So for this topic, the team is always evaluating newer versions of SDKs and generally implementing changes with new versions of Lumberyard. The feedback is still in but just wanted to voice that :slight_smile:

Much thanks for checking out all these topics @Mark.Malewski! I’ve submitted this feedback on your behalf for teams to take further action on. Stay tuned for updates :smiley:

@Amonster_LMBR

Can you please update “Amazon Wwise LTX” to the very latest Wwise LTX 2017.2.0.6500 (based on Audiokinetic Wwise 2017.2.0.6500)? (instead of using a 2+ year old release/version of the Wwise SDK?)

Also can you please add support for the very latest Wwise LTX 2017.2.0 (2017.2.0.6500) SDK to the Lumberyard Setup Assistant?

Also can you please update the Lumberyard Setup Assistant to support the very latest “Wwise 2017.2.0.6500” SDK, and also support the “Wwise LTX 2017.2.0.6500” SDK in the Lumberyard Setup Assistant, and also the very latest CLANG 5.0.1?

Also, has support for the following SDK’s been added to the latest Lumberyard Setup Assistant?

  • Add “Autodesk 3ds Max 2017 SDK” to the Lumberyard Setup Assistant 1.12.0.2

  • Add “Autodesk 3ds Max 2018 SDK” to the Lumberyard Setup Assistant 1.12.0.2

  • Add “Autodesk Maya 2018 SDK” to the Lumberyard Setup Assistant 1.12.0.2

The “Lumberyard Setup Assistant” seems to be using extremely old SDK’s (2 to 4+ years old) and it seems that the Amazon Lumberyard team is not updating the “Lumberyard Setup Assistant” to use the very latest third-party SDKs. Amazon Lumberyard seems to be using extremely old and very outdated (3 - 4+ year old SDK’s). Can you please update the “Lumberyard Setup Assistant 1.12.0.2” to support the above very latest SDK versions?

Hopefully the Lumberyard Team can please begin offering more frequent “minor point updates” (1.12.0.x updates) that can keep up with the very latest third-party SDK’s, and support all the very latest third-party SDK releases for the latest stable releases of all the various SDKs. (Autodesk 3ds Max 2018, Autodesk Maya 2018, Wwise LTX 2017.2.0.6500, FFmpeg 3.4.1, CLANG 5.0.x, etc.)

It would be good if the Amazon Lumberyard Team would include this as part of their daily/weekly/monthly process to continuously update Amazon Lumberyard Setup Assistant to support the very latest third-party SDK releases (or possibly automate the process to modify the Lumberyard Setup Assistant to automatically use the very latest 3rd party SDKs with the latest Lumberyard Setup Assistant). Or at least make sure that each new release of Lumberyard, includes an updated Lumberyard Setup Assistant that is “updated” to support the very latest stable releases of all SDKs, and also continuously release “minor point releases” (Lumberyard 1.12.0.2, and 1.12.0.3, and 1.12.0.x minor patch releases) that support the very latest versions of the third-party SDKs.

Thank-you!

It seems that support for the following SDK’s still hasn’t been added to the latest Lumberyard Setup Assistant (as of Lumberyard 1.12.0.1):

  • Add “Autodesk 3ds Max 2017 SDK” to the Lumberyard Setup Assistant 1.12.0.2

  • Add “Autodesk 3ds Max 2018 SDK” to the Lumberyard Setup Assistant 1.12.0.2

  • Add “Autodesk Maya 2018 SDK” to the Lumberyard Setup Assistant 1.12.0.2

This “feature” has been asked for 2+ years now, and we can’t seem to get any of the Dev’s to take 5 minutes of their time, and please just add these three SDK’s to the latest “Setup Assistant 1.12.0.2” and please just release a point update (Lumberyard 1.12.0.2) with these 3 files/SDK’s added to the latest Lumberyard Setup Assistant 1.12.0.2.

Can you please update the “Lumberyard Setup Assistant 1.12.0.2” to support the above very latest SDK versions? (including Max 2017, and Max 2018 and Maya 2018) and please add these three SDK’s to the Setup Assistant installer?

The “Lumberyard Setup Assistant” seems to be using extremely old SDK’s (2 to 4+ years old) and we seem to have to “complain” for 2-3 years, and nothing seems to be done. It seems that the Amazon Lumberyard team is not updating the “Lumberyard Setup Assistant” to use the very latest third-party SDKs. Amazon Lumberyard seems to be using extremely old and very outdated (3 - 4+ year old SDK’s).

Hopefully the Lumberyard Team can please begin offering more frequent “minor point updates” (1.12.0.x updates) that can keep up with the very latest third-party SDK’s, and support all the very latest third-party SDK releases for the latest stable releases of all the various SDKs. (Autodesk 3ds Max 2017, Autodesk 3ds Max 2018, Autodesk Maya 2018, Wwise LTX 2017.2.0.6500, FFmpeg 3.4.1, CLANG 5.0.x, etc.)

Hi @Mark.Malewski - regarding only the Autodesk product plugins, the reason those are not being updated is that they only support the legacy CryEngine systems. The new FBX import pipeline and Asset Processor no longer require the proprietary file formats which the old CryEngine exporters created, as we now only need FBX files. Thus the legacy CryEngine exporters are no longer supported or updated in line with newer Autodesk software versions. Our recommendation is to move to the newer FBX-based pipeline and not use the proprietary plugins any longer. Hope this info helps.