Lumberyard Beta 1.8 is now available!

Read the GameDev Blog for information on the more than 230
improvements, fixes, and new features included in 1.8:

https://aws.amazon.com/blogs/gamedev/now-available-lumberyard-beta-1-8/

You can find the official release notes for
Lumberyard Beta 1.8 which details all the new features, fixes, and known issues
for this release here:

http://docs.aws.amazon.com/lumberyard/latest/releasenotes/lumberyard-v1.8.html

Download the Lumberyard Beta 1.8 installer on
the Downloads page:

https://aws.amazon.com/lumberyard/downloads/

Yes, let me get those for you.

Wonderful news! Amazon Lumberyard South America Community is already downloading the new packages and SDKs. Thank you.

Thanks Binky!

Interesting! did you guys implemend a new game level? looks great BTW!!

Congrats on the new release!

Is it possible to have the direct download links for the 3rd party libries?

Cool! But:

“The FBX Importer now supports skins, skeletons, and animations.”

This definitely needs to be on the “Highlights” page. First I was disappointed about it still not being added but then I saw it was there. Very nice!

Here are the zips for the 3rd party files. [

https://df0vy3vd107il.cloudfront.net/1.8.0.0/lumberyard-1.8-364057-common-ThirdParty.zip](https://df0vy3vd107il.cloudfront.net/1.8.0.0/lumberyard-1.8-364057-common-ThirdParty.zip)

https://df0vy3vd107il.cloudfront.net/1.8.0.0/lumberyard-1.8-364057-vc120-ThirdParty.zip

https://df0vy3vd107il.cloudfront.net/1.8.0.0/lumberyard-1.8-364057-vc140-ThirdParty.zip

https://df0vy3vd107il.cloudfront.net/1.8.0.0/lumberyard-1.8-364057-winlinux-ThirdParty.zip

I agree, this should be front page on the highlights…

Awesome release, I’m really glad to see there’s been improvements for the fbx imports!

Ouch, I wouldn’t like reinstalling Windows. I like to think that isn’t necessary. Hopefully after they all get back from GDC someone will have time to look at this for you sometime next week.

Can’t say I’ve run into this problem myself. I wonder if perhaps you are running into a filepath issue. On my computer I installed to “F:\Programs\Lumberyard” and the filepath for my AllocationRecords.cpp file is:

F:\Programs\Lumberyard\1.8.0.0\dev\Code\Framework\AzCore\AzCore\Memory\AllocationRecords.cpp

If you didn’t install on the C: drive, perhaps something ended up in the wrong location? Two different versions in different places? Maybe something wasn’t completely deleted from a previous install?

hmm . . . hopefully it won’t take long to track down the problem and it will be an easy fix; hopefully! :stuck_out_tongue:

Good luck!

There is one other thing I forgot to mention. When I first started using Lumberyard I ran into a UI Layout problem I couldn’t fix even by resetting the default layout. I even tried reinstalling Lumberyard in an attempt to fix it and that didn’t work; which surprised me.

In this situation, reinstalling Windows would have fixed it. :o

This is because there is information in the Windows Registry that isn’t being removed. If at all possible, I prefer to avoid playing around in the Registry, but you may want to consider it in this case.

I uninstalled Lumberyard, cleared the Registry and then reinstalled. That solved my problem and you may want to consider that option before reinstalling Windows again. If all goes horribly wrong you’ll end up reinstalling Windows anyway I suppose. :stuck_out_tongue:

I get these errors when trying to run 1.8:

lumberyardbuilderror.png

I have no idea how to proceed. This exact same thing happened going from 1.6 to 1.7 and I only got around it by wiping my computer with a fresh install of windows, and installing the latest version.

Hey @McMunchly, can you post a new thread in the Other Support forum? This will help us properly file and track the ticket and get the issue resolved.

Awesome!