LumberYard Installation error.. Account Permissions Requested

While installing Lumberyard, an error comes up for multiple packages, as below: “Unable to download the file…(installation modules in <<“install required SDKs” in the Setup Assistant>>)…You do not have permissions to access the file you are requesting. Check your account permissions

I have searched alot for any post that may show where are the account permissions to enable, but I keep failing. Kindly assist…!

(a screenshot is attached)

Thank you ! :slight_smile:

lumberyard_error

Apologies, errors of this kind do seem frustrating.

The permission error is more likely on the Lumberyard side (you are downloading the SDKs from our CloudFront distribution and maybe the permissions are somehow wrong for you)

Can you just clarify what version of Lumberyard you are using, forum says LY 1.19 but screenshot appears to be from 1.24.1 ?

Dear Pip, thanks for responding :slight_smile: and yes you are right, the version is 1.24.1.0, and I had just downloaded this version today early hours. So the installation was attempted using the latest version of the installer(setup assistant). If there are any configuration files for me to adjust or change, then please let me know.

Hoping you will be able to guide me… thank you :slight_smile: !!

Hi @lokkkiii, the setup assistant tries to download files to a temporary folder first and then move them to your 3rdparty folder. Is it possible there is some issue accessing the temp folder on the C: drive, or maybe it is out of space?

I’m trying to see where the logs get written just to see if we can see more about what specific error the installer is seeing. However, you’ll get the "You do not have permission to access to the file you are requesting. Check your account permissions when you encounter an AccessDenied/Network issues downloading an SDK from Lumberyard’s CloudFront so it seems unlikely to be related to your machine permissions.

Am running the 1.24.1 downloader to see if I can reproduce (but as my machine is inside the Amazon network so its probably going to work).

Can you download any of the SDKs?

Yes please, I have attached screenshots again, so you can see the packages that are returning an error. Others seem to go through pretty much ok. So np with some.

[If you are a part of awsgametech team, pls find that for some reason there is restrictions on my account where I cannot upload multiple images(as I am a new user), can you pls remove that for me… I am not spaming right? Now due to this meaningless restrictions I have had to combine multiple images into one, causing you the inconvenience to scroll down the image… why cant amazon ban users from posting multiple images when they are reported by users, rather than slapping restrictions on new users to the forum? In this post I am only expressing my experience with installation and answering your queries, and I guess there is absolutely no harm done…)

Thanks for the images which show which packages are failing. We’ve tried a few times in a few different cirumstances to install fresh versions of LY 1.24.1 and download the packages but so far everything has worked.

Can you see if theres anything interesting in the set-up assistant logs? They should be in D:\Program Files\Lumberyard\1.24.1.0\dev\Tools\LmbrSetup\Win\logs\SetupAssistant. They may contain more details about the failures (it is a pretty verbose log, but it would be interesting to see the section where it gets the manifest for AMD_AGS / downloads it)

WRT to the forum preventing new users from posting more than one image at a time, I’ve passed this on to the forum team as feedback.

1 Like

Hi @lokkkiii, allowing 1 image for new users is the default setting for Discourse forums to prevent spam, but we are considering increasing this based on your feedback and the absence of offensive images and spam since the new forums launched. Thanks for your patience! You should be allowed to post more images now.

1 Like

Dear Pip, thank you for your assistance… You have been very kind and helpful so far… But the other day, I just uninstalled the entire package and deleted all folders and then reinstalled it… And this time all the packages went through… So, good news, its working great… Bad news, I didn’t help you find any bug that may have caused it… And, tough news, in the Optional SDKs, I am unable to install Clang, FFmpeg and LibAV even though I have followed all the steps in the instructions by Lumberyard…(those addons i Have separately installed too)

My Request::: Please help users with a complete and packed-in product, instead of requesting users to manually install from internet sources… We do not know which version is compatible with it, and when I look for any older versions of the SDKs, it is very difficult to find them archieves…

Hope you would pass a ping to them Dev Teams up there, so that this process is a little less tedious and immediately ready to use when installed(even if it goes up to 20GB of download size… it doesn’t matter… as people like to start working with it, rather than struggle to just get it installed…)

So far Im enjoying learning this awesome Engine… You may please close this issue as resolved… Have a great day!

Dear petrocket, thank you for responding to this… You and Pip seem really nice and earnest to helping people work with LumberYard… Its great when the support/forum Admins are as quick as you guys to respond and listen out… So far, I have liked the process of learning about LumberYard. But as a new member, if you guys feel I can contribute to this forum in any way, then I would like to get involved and be a part of it… And thanks again, and have a great day again! :slight_smile: :smiley:

Hello Again Pip… After completing the basic training tutorials on youtube, when I finally decided to open the Editor, now I am receiving the following error… I am really not sure what is this regarding… And I am totally feeling helpless trying to just get started with this software… Why can’t this engine be a simple install and run program like Unity or Unreal or even Godot? Some of them charge heavy later and this is free, yes I agree… But Amazon is a world leader in so many fields, and why not with this… I really hope the Dev Team considers making the time spent on this engine a good experience for users who are beginners… Pls help…

Request: Can any one from Developer Team pls contact me, and take all my system logs and do any kind of research they want to do on my system to identify the bug thats causing these issues please?

Trying to load multiple attachments is anyways restricted and I do not know how to get this fixed faster, as I am fixed on using only LumberYard, after seeing the gameplay achieved on this GamePlay (youtube link, check n see)

Hi @lokkkiii, this may be related to an issue I saw recently when installing for the first time. It looks like some of our gems (ImageProcessing) may require Visual Studio redistributables that are not shipped with Lumberyard anymore. Please download and install the Visual Studio 2013 redistributable from Microsoft here: https://www.microsoft.com/en-us/download/details.aspx?id=40784

In addition, please open Windows “Add and remove programs” and verify the other redistributables (2012, 2015-2019) are installed. There may also be an issue where Setup Assistant incorrectly lists them as installed on your device if only some of them are installed.

Hello @petrocket, thank you and yes I have all the redistributables installed as in the screenshot. When I downloaded the package you mentioned above, it asked me if I wanted to repair. So i proceeded with it, and it went through well. I restarted the system and tried lumberyard and it still gives the same error. Plsss request you to let me know any possible solution for this.

EDIT::
@Petrocket, I have downloaded this 85GB(2times of uninstall and reinstall) with my mobile data which cost me almost $14 at a time when I am unemployeed, so I cannot afford to again uninstall and reinstall. Can you or anyone from the Dev Team, pls remote in and solve this problem for me. I am unemployeed and in desperation, after several months of no salary/income, I have looked towards gamemaking as an option. I need help fast so that atleast I can start writing something and publish a game. Its impossible to go out for a job, after some pathetic and inhuman people decided to release an epidemic on the world, taking even some of my friends lives. And hundreds of thousands are on the street with no jobs or income.

Can you guys be considerate in atleast providing quick help so that I can do something for my family? At the pace of one reply a day, it will take 25years to find any bug or even to get the engine to work…

Can anyone be a little more involved with this issue plssss…

Hi @lokkkiii, it appears there is a Gem that is failing to load on startup. What project are you trying to run, the vegetation sample or your own project?

Hi @petrocket I am just trying to start the “LumberYard Editor” from start menu. Previously I tried the below 2 things:::

1 > When the installation finally finished from the “Setup Assistant”, there is the “Summary” section, which has the “Configure Project” button, and when I would run that, I tried clicking on “New Project”… It gave me the same error.

2 > Then when I directly clicked on the “Launch Editor” button in Summary section, it gave me the same error.

3 > Now when I am clicking the “LumberYard Editor” from start menu, it is the same.

So for some reason, it gives me the error for the editor.exe which is in the folder::::
D:\Program Files\Lumberyard\1.24.1.0\dev\Bin64vc142

I tried to even run it as Admin, and in compatibility mode, and lastly today, due to a hopeless feeling looming here, I opened the website POST and downloaded the " Client Zip Files " for PC and copy pasted it over the existing folders of the 3rd Party folder in my PC and now again, multiple addons are showing as pending to be installed.

If you know how to remote in and solve this problem, can you pls do so? I really want to get started with this.

@lokkkiii, Lumberyard requires extra setup if you want to create a new project and not just run samples, so I’d like to confirm you followed the steps in the Setup Assistant documentation.

If you have completed those initial steps successfully, how far do you get when following the “Creating a new project” documentation?

Based on your screenshot above (the one that says the editor failed to startup because it couldn’t load the video playback gem) it looks like you were able to run the Project Configurator and create a new project with the Video Playback Gem enabled or installed some project that had that gem enabled, is this correct? If so, there was probably some issue with compiling the project, but would like to confirm you have attempted to compile a new project first.

Dear @petrocket , Yes please that is exactly what I have been telling since the beginning. I am not trying to run any sample project, I am least interested in it. I was only exploring the website for terrain, while goign through the tutorials.

But when I completed the tutorials, I was only and only trying to open the “”"“Lumberyard Editor”""" (like shown in screenshot) which is in the ‘start menu’(above the Setup Assistant, so that I can have a look at it, first. Please eliminate the theory if I was running any of them samples, which I didn’t… Since the beginning I was trying to open the Editor.exe (which is in D:\Program Files\Lumberyard\1.24.1.0\dev\Bin64vc142) and try to have a look so I know what it feels to look with the editor. By my bad luck, the background was a vegetation sample project, and the queries are only if I am trying to open a sample project, which I am not…

I am directly trying to click on the screenshot related buttons from 4 places, and all of them give the same error… Please forget any sample project, which I have never even tried to open yet plss…

Edit::

  1. And as you have pointed towards the “videoplaybackframework” Gem, I have been trying to find a way to get the missing dll file that it is throwing in the error. Is there anyway that I can get that file?

  2. And also, the second error in the Reply above , which is about failing to initialize the CryEngineSystem, and says I need to whitelist an IP, I am clueless of what it is asking me to do. Any suggestion on the second error please?

@lokkkiii, in the screenshot it shows StarterGame as the active project (it has a checkmark on the image) so the editor is trying to load the gems for that project, but that project doesn’t use the video playback gem which is part of my confusion.
Did you add the video playback gem to StarterGame in Project configurator? If so, you will need to recompile the project before running it.

The “Create new” button in the project configurator should not launch the editor - it should open a form allowing you to enter a project name and build it.

Were you able to get through the tutorial on creating a new game project and the project compiled successfully?

UPDATE - I should provide the link for building an existing project https://docs.aws.amazon.com/lumberyard/latest/userguide/game-build-intro.html Please note if you are using Visual Studio 2019 you will need to use

lmbr_waf configure
lmbr_waf build_win_x64_vs2019_profile -p all

Thanks for hitting back @petrocket … for the previous reply there is an edit which I am pasting below:

  1. And as you have pointed towards the “videoplaybackframework” Gem, I have been trying to find a way to get the missing dll file that it is showing in the error. Is there anyway that I can get that file added back in the main folder?

  2. And also, the second error in the Reply above , which is about failing to initialize the CryEngineSystem, and says I need to whitelist an IP, I am clueless of what it is asking me to do. Any suggestion on the second error please?

Also, for your most recent update, it threw me an error.

Just guessing, is the space in “Program Files” causing all these issues to happen?

My C:\Program Files also exists, which happens to be the default. But I installed lumberyard in D as I have no space in C drive

@petrocket When I am trying to install the FFmpeg or LibAV SDK, its just giving me an error that “The contents of the file do not match the checksum.” Also, I am not sure which versions are compatible(should I go with the latest ver of SDks(ffmpeg/libav) or the versions mentioned in Lumberyard(because I have tried both, and they give out the same error))

Kindly guide me to a page on https://docs.aws.amazon.com/index.html where I can find instructions on adding the 2 libraries correctly please… That would be really appreciated :slight_smile:

And there are a few folders in “Lumberyard\1.24.1.0\dev” which are namely, ‘cache’, ‘SamplesProject’ and ‘StarterGame’. I understand that these are the officially provided samples of a LumberYard project, but is there any safe way to remove it please.

Thank you